Not Enough Memory

Specifications:
Not enough memory

Diagnostic Info

Processor: Intel Core i9-10900K CPU A3.7GHz

Installed Ram: 64GM

Edition: Windows 11 Pro

Docker For Windows Version: 2.4.0 (The most recent version that doesn’t
cause my processing node to go offline)

How do I fix the Not Enough Memory issue?

This should help you, I had the same problem.

2 Likes

I can’t do anything except the “default” option for WebODM at this time, here is what I tried to fix it.

  1. wslconfig file: I could not get the commands to work correctly in the Command Prompt.

  2. I turned off the WSL2, gained access to the allocations, set it to 10 cores, 48G of RAM, and 400G of storage.

On the “default” settings, I can run the orthos, but anything related to the 3D model, or even selecting the “3D Model” option gives me the same “Not Enough Memory” error.

The good news, I am on the new Docker for Windows now and the node is online. So, it’s progress.

  1. For the wslconfig, you’re not entering commands, you’re editing a text file that gets read by Hyper-V/WSL:
  1. Have you verified how much RAM is actually accessible when using the non-WSL2 method?

I created an issue while trying to get everything to work and had to reset my PC. Now, everything is working, the maps are created very fast on my PC. I just did the default “3D” option, it took 27 minutes with 350 Zenmuse P1 camera. WebODM worked great, I will be conducting several test flights in the near future to fine tune my workflow and to test WebODM capabilities. The 3D model was good, but not great, I need to adjust some settings, possibly. Also, I will use RTK on the next project and on the last project RTK, GCP’s and Check Points.

I did NOT change any settings with WSL, I allowed windows to allocate everything.

2 Likes