Noob trying to get the hang of things (lots of questions)

Ive been drone mapping for about a year now and have used mostly Metashape up until now. I’m trying to make the change to WebODM but I’m having issues gettiing up and running. I just downloaded the Lightning app but what I’d like to do is process my datasets natively on my computer not on any cloud server which correct me if I’m wrong is what Lightning is? So my question is what exactly do I need to do to setup a processing node on my computer? When I signed up originally i paid the extra for the installer but I still seem to be having issues figuring it all out. I’ve got docker desktop running and through the web portal version can process, I’ve got another node (other than Lightning) setup there named Node-odm-1 but with the ‘WebODM Lightning app’ for windows the only processing node available is the one named Lightning that takes credits which isnt what I’m trying to do. Can someone please explain what it is I’m doing wrong and hopefully what I can do to fix it? I like to think I’m pretty technology savvy but this is giving me fits trying to figure out. I’ve built my own computer which I’m pretty sure is gonna be alright to process (worked fine with Metashape). My specs…
Ryzen 7 3700x
Gigabyte A520I-AC mobo
OLOy RAM 32gb 3200 mhz
SP nvme M2 500gb ssd
PNY sata 500gb ssd
WD 1tb hdd
EVGA 1650super
ID-Cooling Auraflow 240 AIO

Wasnt sure if the specs were needed or not but figured better safe than sorry lol. Any help with where this is all going off the rails would be appreciated. Thanks…

Yes (it’s a cloud service). Yes you need to setup a NodeODM node if you want to process locally.

If you have docker running, simply open a command prompt and issue:

docker run -ti --rm -p 3000:3000 opendronemap/nodeodm

This will launch a node.

Then from WebODM use the IP address of the machine running the node (port 3000) to add a new node.

1 Like

Thank you very much sir…that did the trick. I appreciate you taking the time to help me out. Have a good day.
Thanks again…


It worked for a bit and now it says “Node1 appears to be offline” lol… Not sure what I need to do to bring it back online? This is in the WebODM Lightning App. If I go the other route that loads in my web browser that still loads and works normally. Does it make a difference that they both use port 3000?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.