NodeODM, docker and s3


It’s me again. I am still learning and testing the various and amazing tools at our disposition.
I tried to add and s3 (a space from DigitalOcean), it works like a charm on the windows NodeODM exe but when I add the --s3_endpoint parameter to my docker line I have the following error : unknown flag: --s3_endpoint.

My docker line is the following :

docker run -p 3000:3000 --s3_endpoint --s3_bucket myBucket --s3_access_key myAccess --s3_secret_key myKey --s3_upload_everything opendronemap/nodeodm

Am I missing something ?

1 Like


docker run -p 3000:3000 opendronemap/nodeodm --s3_endpoint --s3_bucket myBucket --s3_access_key myAccess --s3_secret_key myKey --s3_upload_everything

Thank you, it worked.

I should have try to permute the parameters…
Sorry for this.

I had try this command line based on the of NodeODM equivalent for gpu.

docker run -p 3000:3000 --gpus all opendronemap/nodeodm:gpu

Should the readme be updated ?


That command is correct; the --gpus parameter is a docker parameter, so goes before the image name.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.