NodeMICMAC processing forever

Hi all,

I’m new here, and some things might be very obvious to you but alien to me. I have already searched for this particular behavior on the forum, but not found anything.

I’ve used WebODM successfully for a little while, and installed an accessible node on a second machine. Now I’ve tried installing NodeMICMAC on my main machine. However, I am not getting any results when using it, it seems to work full speed forever.

I am testing with a dataset from the Pix4D tutorial, which contains 13 geotagged images and one GCP-file edited to the WebODM format. I’ve used it for benchtesting the WebODM settings and nodes on the different machines, running successfully at ca 8min and 25min using default and High Resolution settings on the normal nodes. When trying NodeMICMAC, all cores are engaged and it has currently been running for almost 35hrs - which seems excessive for a 13 photo dataset.

I previously tried a different set with geotags, but no GCP file, and ended it after 8hrs - Edit: for clarity: It never finished, I ended the process because I needed to use the PC for something else.

It does not seem to be doing an infinite loop, or stopped processing, as the log output still changes.

Has anyone else seen similar behavior?

The latest output looks like this, there is other information occasionally, the bracketed numbers change - it is also down to 11 Images loaded from yesterday:

TCor 3585.41 CTimeC 11.5863 TOpt 1679.06 Pts , R2 0, RN 0 Pts , R-GEN 99.9937, Isol 0.00627367 PT 3.09452e+08
DO ONE BLOC [5043,9480] [5119,9560] [5005,9442] MATP 0
11 Images Loaded
Correl Calc, Begin Opt
TCor 3692.36 CTimeC 11.5683 TOpt 1743.23 Pts , R2 0, RN 0 Pts , R-GEN 99.9937, Isol 0.00630553 PT 3.1918e+08
DO ONE BLOC [5119,9480] [5196,9560] [5081,9442] MATP 0
11 Images Loaded
Correl Calc, Begin Opt
TCor 3792.01 CTimeC 11.5819 TOpt 1796.94 Pts , R2 0, RN 0 Pts , R-GEN 99.9935, Isol 0.00650653 PT 3.27409e+

1 Like

I suspect there might be some scaling issue? Perhaps due to the GCP data? The coordinates are in EPSG:2056 (CH1903+ / LV95). However, that does not explain why the dataset without GCPs took 8+ hrs, and it worked very well on the other nodes.

The only thing I changed when starting it (Edit: from the NodeMICMAC web interface directly) was to generate 2D and Potree tiles, and set Max-concurrency to 8.

1 Like

Welcome!

Sorry you’re having trouble!

Are you able to share your full processing parameters and your dataset?

Saijin,

During my troubleshooting I deleted and reinstalled the MICMAC node, and it took the console.txt with it. However, I have the same issue with the new node by the looks of it. I put images, GCP file and console.txt from my latest attempt it in the Dropbox folder below:

The difference is that this was started from the WebODM interface with default settings, my previous was started from the node-web interface with 2D tiles and Max concurrency to 8. The result seemed to be the same in both (all) instances (also with different datasets).

1 Like

I’ve been busy with some other projects, but picked this up again yesterday. I downloaded the 4thAve sample set from github (GitHub - OpenDroneMap/NodeMICMAC: A Lightweight REST API to Access MICMAC Photogrammetry and SFM Engine.), and ran it for testing instead, and the node worked fine. So it confirms that the issue lies with my test data, not the node.

The thing that confuses me at the moment is that the options in the drop down for the Micmac node in WebODM is not the same as the options when you go to the Micmac node web interface…

I would like to have all the data available in WebODM, but to get a point cloud for viewing it seems like I have to select the option and process it in the Micmac node interface, download the .zip file and import it in WebODM again? Is there something wrong with my setup, or is this normal?

1 Like

I’m not sure how tigtly integrated NodeMICMAC is given that it generally does not get much maintenance or pull requests.

It might need some love :thinking:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.