Node-odm-1 offline error

Browser: Chrome
OS: Windows 10 Pro
Install Process:

  1. Installed Git
  2. Installed Python 3.7 with Add Python.3.X to PATH checked
  3. Installed Docker from https://download.docker.com/win/stable/Docker%20for%20Windows%20Installer.exe

4.Allocated half of the CPUs (2) to Docker and 70+ percent memory
5.Used Git GUI to clone the repository at https://github.com/OpenDroneMap/WebODM
and ran ./webodm.sh start in Git Bash

At localhost:8000, WebODM was running. I created a login then attempted to upload some images. I received an error asking me to check permissions. I applied the all available permissions to my login, group (Default), and the node. Attempted to upload the same images again and received the same error regarding the node. When I check the node, it says it is offline.
Did a docker rebuild and reboot, now WebODM won’t start up on the localhost at all, though it appears to start fine:

$ ./webodm.sh start
Checking for docker...   OK
Checking for git...   OK
Checking for docker-compose...   OK
Starting WebODM...

Using the following environment:
================================
Host: localhost
Port: 8000
Media directory: appmedia
SSL: NO
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1
================================
Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
Starting node-odm ... done
Starting broker   ... done
Starting db       ... done
Starting worker   ... done
Starting webapp   ... done

Try ./webodm.sh --restart.

1 Like