No results in ODM. Worked fine in WebODM + Lightning Network

Hi, I have a dataset of 368 photos. ODM failed processing these photos. Log results

Prior to December 2020, I was able to get ODM to run on my 2016 MacBook Pro 13" 16 GB with Docker. Yesterday, I turned up the resources for Docker and did a pull for opendronemap/odm:latest and I thought I got things running again. However, this morning when I checked the folders, there was no odm_texturing, odm_orthophoto, odm_dem… I did have things in an opensfm folder. I’m not sure how to decipher the log with the results.

I decided to try the Lightning Network and it worked there. Any idea why I would get different results?

Welcome!

It looks like your memory allocation to your docker instance is really quite low, especially given that you only have 2GB of SWAP allocated to it as well ontop of the 8GB(ish) of RAM.

Try increasing SWAP, RAM, and giving it another go.

If not, try backing off on the quality settings.

2 Likes

Thank you so much for these tips! I will try tonight. :blush:

2 Likes