New Install Error 132 codes and virtualenv has stopped

Hi guys,

Wondering if I can get any help.

New install on a windows 8 machine HP600 workstation with dual Xeon x5670 processors, 32gb Ram, 250gb hard drive with 75GB free space on the disc… I purchased the USB WebODM image and created a bootage USB.

Programme starts up in firefox but I immediately get a pop up crash report saying ‘Sorry the application virtualenv has stopped unexpectedly’ this goes away on its own after a while, and I am able to go into the software.

I have tried to process a data set of 100 images I took, then just 7 images and always get after around 6 seconds a ‘Process exited with code 132’

i checked the spec on the processors and they were released March 2010 so should meet the spec? Virtulisation is switched on.

In OpenODM when I look under the tabs is says system has 32gb ram and 15gb disk space… but it wont even work when I try to process 7 jpgs of around 25 megapixels.

Any ideas… when I paid for this did it mention we get support? Can I contact support or it is this forum?


1 Like

Thanks for supporting the project!

Installation support, yes (for that, contact Contact - UAV4GEO).

For questions about usage/processing datasets, this is the right place.

Try to process more images! 7 are usually too few. Also, make sure they have enough overlap, that they are in focus and share the same focal length.

1 Like

Thanks for your replu. Sorry yes I have tried to process a full 200 images from a data set of crossed flight paths, 100 from one flight, 7 just to see if I got the same error… all the same… all overlapping at 84%

Can you post the full task output? Also, are you able to process a dataset such as GitHub - pierotofy/drone_dataset_brighton_beach ?


Hi Peirotofy, thanks for your help.

So no I cannot process that Brighton Beach data set, I get exactly the same problem, after 6 seconds of processing a Process exited with code 132

The task output says:

/code/ line 5: 3670 Illegal Instruction (core dumped) python3 $RUNPATH/ “$@”

My computer was released march 2010… sounds like it could be too old? I managed to create the bootable USB but have no idea how to compile my own docker image? Can I do that via the bootable USB method?

Sorry just as a third update I just checked my Xeon X5670 processor specs and it says it was first released March 2010 and supports MMX, SSE 1-3 and SSSE3 so it should work?

Actually up to SSE 4.2.

Something else seems like it is going on, here.

Yep, it’s just below the “cut-off” for our build. So the error is due to an unsupported architecture.

The workaround would be to install the USB image (don’t run it from USB, actually perform the installation if that’s an option), then from a prompt:

sudo su
cd /code
bash reinstall
sudo chown -R odm:odm /code

It will take a while, but will recompile everything and will thus enable you to run the software.

1 Like

Thanks, I’ll give that a go and let you know. Cheers


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.