Native windows webodm

The 1156 image set worked ok, and only used up to ~50% of the memory, and I did get the full 1607 image set to produce an orthophoto running with Docker, so not yet given up hope :slight_smile:
I do realise I may need to put in another 32GB to reliably do larger sets.

Same issue after restarting, it just sits there Queued. Closing Web ODM doesn’t kill the process, it stays running with just over 50% of memory in use, mosltly due to Python.
BTW, I installed the latest version last night before I started running into the Queued problem.

I’ve just tried to do a run with the full set of 1607 images, set to High Resolution, with resizing to 2048, and after uploading to processing node, it immediately went to Queued. A maximum of 55% of memory was used during the uploading, so I would think that it is not a memory problem.
Again WebODM processes did not stop after closing the program, with Python memory and CPU usage continuing to increase.

I deleted tasks.json and was able to progress to trying the 1607 images at reduced resolution for an orthophoto, which did work in Docker with a bit less available memory, but it appears to have come to a stop (nothing happening for well over an hour), even though memory usage at the time was only ~30%.Usage had been up to 87% earlier during processing, but had come well down before it came to a halt, no error messages were shown.
Console log here:

UPDATE: Although it looked like nothing was happening for nearly 2 hours- memory not changing, low CPU usage, it has come to life again with up to 100% CPU and memory varying, so I’ll let it continue :slight_smile:

After a few more hours:

100 - done.
[INFO] Exporting report to C:\WebODM\resources\app\apps\NodeODM\data\ba85f4f7-e786-43a3-92a3-865b1526d4a7\odm_report\report.pdf

but nothing for hours, CPU is down to ~9% and memory usage ~600MB, and canceling does nothing with the program hung, so had to close it.

Well it works on my laptop, but I get the same “cannot process dataset” as explained above on my desktop every time. No idea why.

@bevingtona, can you share the CPU specifications of the desktop machine that is failing (which CPU is it?)


Thanks @pierotofy !

Here is the info:

Despite the apparent failure to progress beyond this step:

I had a look around in \WebODM and found it was there, along with all the other produced files!
So it seems it is just the log window that isn’t updating to show completion, the files exist, and you just have to search for them.

BTW, that demonstrates that 1600 images from my M2P drone, with images reduced from 5472 to 2048 pixels, can produce an orthophoto on a computer with 32GB RAM, both in the native Windows version and running under Docker :smiley:


Check this out: Processing Node - Queue does not clear in native windows webodm - #12 by pierotofy

I’m on #14 now, but deleted tasks.json manually earlier as suggested by pierotofy.

Hello,i meet the same problem,hava you solved it.
Thank you.

To all those whose tasks are getting stuck in “Queued” state: if you go to ToolsReset Processing Queue are you able to get it unstuck?

1 Like

i have not been able to solve :frowning:

This topic is for native windows webodm or native windows ODM? …I can’t find the native version of webodm on github, thanks

Hi, i have problem with native web odm.

  1. During proces ( 10 pictures) i have a error : Procesing node went offline. This could be due to insufficient memory or a network eeror.
    My pc: 6x3,6ghz, 16gb ram ddr4, SSD.
  2. During proces the use processor is 60% and ram 30%, when in web odm with docker the usage ram and procesor was a 90%.
    Plase help.
    WWconsole.pdf (147.1 KB)

I’ve found Memory and processor usage in the Windows version is significantly less for the same image set, partly due to not having to run Docker simultaneously.

1 Like

After upgrading to the latest version yesterday, all my orthos, DEMs etc, and surrounding base images have white vertical lines on the screen, as per this image:

It looks like your browser window is zoomed. Can you try resetting the browser window zoom to 100%?

It became zoomed out when posted in here, but isn’t. If you open the image in a new tab, it displays as the correct size.
The lines were in ver. 14, downloading 16 now.

EDIT: The lines are there in ver.16 too.

1 Like

Currently, the native installer for Windows is being extended to previous paid customers (past year) as a thank-you, with a 50% discounted upgrade path for other customers. Have you ordered from UAV4Geo/OpenDroneMap in the past? If so, you should have received an email in the past week or so with a link to the installer. Check your spam folder.


I’m sorry you’re having issues with processing at the moment.

Are you able to link to your dataset anywhere? or another cloud provider?

For the time being, can you try re-running it with a lower max thread count? I’m curious if that might not help you avoid an Out Of Memory issue.

1 Like

I have a data set on my computer, I do not have a data cloud.
I’m working on a native ODM web so I can’t reduce the number of threads.
Anyone else have any idea where this error could be from?