Native windows webodm


Should! The architecture between Win 8.1 and Win 10 is fairly close.

Feel like giving it a shot and letting us know?

Hi Saijin_Naib

  1. Unfortunately, I have Win 10 Home which does not have Group Policy Editor.
  2. So I tried to enable long paths using regedit. Reboot. Did not help.
  3. I found a method to install gpedit.msc. Enabled long paths successfully. Reboot. Did not help either.
  4. Out of curiosity I attempted processing without resizing the images. That appears to be working. It is about 1/3 through processing the 65 images as I write.
    Thanks for your help.
1 Like

Windows Defender

1 Like

Try to add the WebODM folder to the list of exclusions: Add folder exclusion - Windows Defender Security Center - Digital Assessment - Wiki.nus

1 Like

Trying out the Windows native WebODM, looks great, but haven’t been able to get it to succeed at any task yet.

I keep getting:
Processing node went offline. This could be due to insufficient memory or a network error.

This is for 65 images and the default processing setting. I have 128 GB RAM and a powerful computer, so not likely a memory issue…

Any thoughts? Thanks!!

1 Like

I was running version 11, I’m currently trying with version 12 and it seems to be working, stay tuned!


I’m running 32GB RAM and there is plenty of disk space available. I was able to run the default settings with the same resizing of images on the WebODM version. This time I just tried DSM and DTM.

.zip files can’t be uploaded to the forum, so I’ve placed it here for downloading:

1 Like

Thanks Yu-Huang_Wang but i have no idea where to do this.

1 Like

Hi Peter,

You can download the All Assets ( of a task on your Docker WebODM (Fig. 1). Then, create a project on your native Windows WebODM and import the file (Fig. 2). It will take some time to import the assests. But this does not include the original images.


Fig. 2

Fig. 3-4


Anyone receive this e-mail about the webODM naitive install? Is the link legitimate?

1 Like

Yes, it is legitimate.

I received it as well!

1 Like

Yes. You can verify the executable’s digital certificate too (it contains my e-mail).

1 Like

Thanks again Yu-Huang_Wang. I could not see the tree for the woods!

1 Like

thanks for all your hard work and dedication in developing and maintaining odm.
Allocation of storage. Storage seems to be on the drive the program was installed. I have a separate ssd for these projects. Can I designate which drive to use for storage?
windows 10 5950x 128 Gb ram Aorus master 1Tb ssd programs 2 Tb ssd work/projectwinodm02

1 Like

Maybe related to my previous post on storage - see error message on attached screen.
Running native Windows webodm, docker still installed from previous webodm.
windows 10 5950x 128 Gb ram Aorus master 1Tb ssd programs 2 Tb ssd work/project

1 Like

Still unable to get it to succeed on the Windows 10 with the new WebODM version 12. The same process and images works with Lightning, just not locally.

Thanks for any help you can offer :slight_smile:

The error message is:

Cannot process dataset

The last chunck of the task output is:

[INFO]    running gdalbuildvrt -resolution highest -r bilinear "E:\WebODM\resources\ap    p\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\merged.vrt" "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\tiles.small_filled.tif" "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\tiles.tmp.tif"
...60...70...80...90...100 - done.
[INFO]    running gdal_translate -co NUM_THREADS=48 -co TILED=YES -co BIGTIFF=IF_SAFER -co COMPRESS=DEFLATE --config GDAL_CACHEMAX 42.25% "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\merged.vrt" "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\tiles.tif"
Input file size is 3349, 1411
..90...100 - done.
[INFO]    Completed mesh_dsm.tif in 0:00:02.384653
[INFO]    Sampling points from DSM: E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\mesh_dsm.tif
[INFO]    running "E:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\dem2points" -inputFile "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\mesh_dsm.tif" -outputFile "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\dsm_points.ply" -skirtHeightThreshold 1.5 -skirtIncrements 0.2 -skirtHeightCap 100
[INFO]    running "E:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon" --in "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\tmp\dsm_points.ply" --out "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\odm_25dmesh.dirty.ply" --depth 11 --pointWeight 4 --samplesPerNode 1.0 --threads 47 --linearFit
[ERROR] Failed to open file:
[INFO]    running "E:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\ReconstructMesh" -i "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\odm_25dmesh.dirty.ply" -o "E:\WebODM\resources\app\apps\NodeODM\data\a876a1ad-56f3-4d30-b8a8-79bb0ffa304b\odm_meshing\odm_25dmesh.ply" --remove-spikes 0 --remove-spurious 0 --smooth 0 --target-face-num 400000
===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
===== Done, human-readable information to follow... =====

[ERROR]   Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See
Traceback (most recent call last):
File "E:\WebODM\resources\app\apps\ODM\stages\", line 83, in execute
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 338, in run
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 338, in run
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 338, in run
[Previous line repeated 2 more times]
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 319, in run
self.process(self.args, outputs)
File "E:\WebODM\resources\app\apps\ODM\stages\", line 66, in process
mesh.create_25dmesh(tree.filtered_point_cloud, tree.odm_25dmesh,
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 42, in create_25dmesh
mesh = screened_poisson_reconstruction(dsm_points, outMesh, depth=depth,
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 178, in screened_poisson_reconstruction'"{reconstructmesh}" -i "{infile}" '
File "E:\WebODM\resources\app\apps\ODM\opendm\", line 90, in run
raise SubprocessException("Child returned {}".format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1
100 - done.
1 Like

Hi, I see there is a simple solution to printing a map, use the Print Screen key. Color me dumb.

Yesterday I ran a large subset,1156 of the 1607 images that initially failed, and kept an eye on memory usage. Generally it was below 50% of 32GB, so not sure why the full set of images failed.
Used a screen grab to avoid the white in black with no detail image when using export.

1 Like

Now I’ve tried to go larger with 1600 images, but after resizing to 2048 has completed, nothing happens, the progress bar just says “Queued”. Memory is about 50% full, Python using >8GB and ~17% of CPU, but nothing obvious happening. It’s done that twice in a row, I deleted the previous attempt but the memory usage by Python stayed high, even after stopping and restarting Web ODM.
I’ll restart the computer and see what happens.

EDIT: just did a few Windows update and now notice that Python is using over 10GB, and was briefly using 100% CPU. It’s an out of control memory consuming monster!

I don’t think you can reliably process more than ~1,000 - 1,500 images with 32GB. It’s just not enough memory. You might get by if you splitted it by setting split to 600. Maybe.