Native web odm problem memory

Hi, i have problem with native web odm.

  1. During proces ( 10 pictures) i have a error : Procesing node went offline. This could be due to insufficient memory or a network eeror.
    My pc: 6x3,6ghz, 16gb ram ddr4, SSD.
  2. During proces the use processor is 60% and ram 30%, when in web odm with docker the usage ram and procesor was a 90%.
    Plase help.
    WWconsole.pdf (147.1 KB)
1 Like

Can you post your machine specifications (what kind of CPU do you have, operating system, etc.). A screenshot of your System information application will do.

Also, can you tell us if you’re using an antivirus software?

I’ve heard of a few other reports of this problem, but haven’t pin-pointed the cause yet.

1 Like

MSI B450a pro
GPU MSI GTX 660

CPU Ryzen 5 2600
Memory GSkill Aegis 3000mhz 2x8gb DDR4
Hard Disk 2x256 SSD
CPU virtualization enabled
Antivirus Eset Internet Security
Windows 10 pro x64 bit

2 Likes

Could be caused by Ryzen CPUs (?)

Another user’s specs that reported this issue shows a Ryzen CPU:

image

1 Like

Hello,

No, the same error on Intel platform:
i7-8700 processor,
48GB Memory
Windows 10 Pro x64

212 photos
Processor usage: 100%
Memory: 30%

“Processing node went offline. This could be due to insufficient memory or a network error.”
Not resized images: getting error on feature search after 12 minutes running time.
Resized images: after 18 minutes.
Processing node, actually, running after error message: processor usage keeps on 100% level.
Tried to wait till processor calmed down, then restart the task: task finishes with some results. The results are not comparable with the results from Docker based WebODM with identical tasks options: the point clouds are not dense enough to create good 3D model. Same task setting makes almost perfect results on the same computer with Docker-based WebODM.

Thank you.

1 Like

Thanks for the report @CraneZ. What happens if you set a max-concurrency parameter to 4 or 8? This will slow down processing time, but are you able to complete processing then?

1 Like

Does anyone have any idea in something there may be a problem?

1 Like

We’re still investigating. No luck for now. It seems that the process is somehow “blocking” (hang? freeze?) the computer for more than 5 minutes in the initial steps of processing. When that happens, WebODM assumes the node went offline because it hasn’t been able to communicate with for it more than 5 minutes, so it errors out. But it’s strange. Do you notice any “hanging” of the computer window or resources when you first start processing?

The fact that it seems to run fine on my machine (and plenty of other machines) makes this difficult to track and fix.

1 Like

Yes, at first I saw that the window was freezing for a while and then it returned to normal.

1 Like

I’ve made some changes to the offline check; in a few hours, try to update by going to Tools → Check for Updates. Build 19 should address this. Please report back if the problem persists even after the update? :pray:

1 Like

Thank you very much, I will check tomorrow and of course I will answer if it works :slight_smile:
By the way - is there any plans to generate an ortho photo map from a polygon ground that could be drawn?

1 Like

Can you expand on this? You mean cropping around a known polygon?

1 Like

Yes:) For the program to generate an ortho photo from a known polygon.

I made a few tries and there was no mistake so far :slight_smile:
What about low-level CPU and memory usage?

Still being investigated.

1 Like