More than 100 images corrupts the output

Hey, sorry if this is a noob question and asked before/something obvious I’ve missed.

Everything works fine if I process up to 100 images for an Orthomosaic. I’ve got a site consisting of 327 images, which when entered the output looks like its only tried to render 100 of them - and usually looks “wavey” or disfigured.

I tried searching the forum for useful posts but I’m not even sure what to look for - Any help would be greatly appreciated.

*Some examples:

(works great) First ortho with 100 photo’s: Ortho1

(works great) Second Ortho with 150 photo’s: Ortho2

(fails) Third Ortho with 200 image’s: Ortho4

(fails) Fourth Ortho with all 327 image’s: Ortho3

1 Like

Seems also that the ortho does not fit so much with the underlying map. I’ve a few moments ago finished a 234 images task and the deformations are only at the edges over my focus area where I knew I didd’nt get enough overlapped images.

1 Like

The first two are aligned where they should be - The 2nd two (when it fails) it seems to just throw them anywhere. I’m pretty sure I flew with at least 80% overlap, if not 90%.

1 Like

Welcome! We’ll do our best to help you out!

Are you able to post your data and processing parameters somewhere we can take a look and experiment with?

Hi Saijin,

Im running it through WebODM lightning at the moment with my 150 free credits in the hope I’ll get something usable relatively quickly.

I’m uploading the 327 images to a onedrive account - Would it be okay if I send you a link to it once its done via pm and you could try them?

Thanks.

Mike,

Honestly, I may not be the best person to assist! I’m still learning how to operate optimally within ODM, so if you are comfortable, posting a public link allows many other folks to get eyes/hands on, and will likely lead to you getting better help than from me alone.

If not, then a PM link is fine :slight_smile:

So the WebODM lightning finished with less than ideal results: Ortho5

again only about a 3rd of images were processed. It might be something completely obvious im missing but any help would be greatly appreciated.

If someone else could try running the images it would be most appreciated. The photos can be downloaded here: https://1drv.ms/u/s!AlDI5_5RbdmO2zxNx4r-WTN1L1bz?e=1HtEi9

1 Like

I’ll give a try, hope ram is enough

1 Like

I know, right? I’ve only got 32GB.

I just completed a job with 330 images with no issues - other than time taken to complete.

I had similar issues - until I increased memory and disk allocation for Docker using the WebODM interface.

I gave Docker 48 GB out of my 64 GB of RAM - and about 250 GB of storage. Could likely do with less RAM, but might as well give it as much as possible while still being able to run other apps.

Also, changed from 19:9 to 4:3 - which has been suggested elsewhere to be a much better aspect ratio for processing.

1 Like

Could you possibly try with the images provided and send me the output? I’m desperate at the moment and would be more than happy to pay a wee bit to know that this all works.

Thanks,

1 Like

I am downloading the images and will give it a try- on a very slow Internet connection today, so the job may not kick off until tomorrow evening my time (EST)

1 Like

thanks so much, I’ll continue to try things and let you know if I have any success. I really appreciate everyones time and effort to help.

1 Like

Have you assigned extra ressources in the Docker Config (Right the Docker icon in the task bar/top menu bar and select Preferences’
image

1 Like

I’m running it on my WSL2 instance locally, so whenever (if it does) finishes, I’ll link you to the final outputs.

I really need more than 32GB RAM -_-

1 Like

This might sound crazy, but I cant find an instance of docker running… I’ve got a process “Docker-compose.exe” but I cant find anything to interact with.

When WebODM is running - I have a Docker symbol in the top menu on my Mac:

image

I right click that one. I am using the WebODM Mac installer purchased - don’t know if the free version uses Docker

running the paid for Windows version - No sign of docker in my toolbar. I have a “docker quickstart terminal” icon on desktop and “Oracle VM Virtual Machine”.

I am in a Mac - so the main difference is that the Docker icon is likely at the bottom right of the screen. It might be hidden behind a small triangle, opening more items.

Can check my Windows PC when back tomorrow. But prefer my Mac, as WebODM so far has not crashed on it

Ok I have the run, it tooks 1h on my HP Z620 24 Gb ram esa xeon E5 2620 with linux opensuse 15.2.
I’ve run it with the default with resize to 2048.
Obviously didn’t work but the interesting thing is that the point cloud has a nice barrel vault effect and looking at the model seems that the normals are inverted.
Try to put a link to the whole asset and some screenshots:


Here I leave the word to the experts, over my skills venture any theory!
hope it helps
ciao
luca
Screenshot_1

Screenshot_2

Screenshot_3