Missing input in order to use GCP for georeferencing. Using EXIF data instead

I havent seen a posting regarding this issue. So I’ll ask. I have a data set. I’m trying to use GCP’s to correct it. I create the GCP file using WebODM control point inter face. I process and get this message in the georeference log file.

“Missing input in order to use GCP for georeferencing. Using EXIF data instead”.

Can any of you point me in the right direction to correctly geo reference my project? Is it the control configuration? File formatting?

Below is the entire georeference log file:


Arguments given

















Reading cameras from: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/opensfm/bundle_r000.out

Reading transform file from:

Reading cameras gps exif positions from: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/coords.txt

Reading textured mesh from: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_texturing/odm_textured_model.obj

Writing output to: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_texturing/odm_textured_model_geo.obj

Log file path was set to: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/odm_georeferencing_log.txt

Transform file path was set to: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/odm_georeferencing_transform.txt

Georef file output path is set to: /var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/odm_georeferencing_model_geo.txt

Missing input in order to use GCP for georeferencing. Using EXIF data instead.

Reading mesh file…

… mesh file read.

Applying transform to mesh…

… mesh transformed.

Successfully saved model.

Saving final transform file to ‘/var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/odm_georeferencing_transform.txt’…

… final transform saved.

Saving georeference system file to ‘/var/www/data/204b15c7-7bf4-4902-884c-118d2d3630f0/odm_georeferencing/odm_georeferencing_model_geo.txt’…

… georeference system saved.


Hey Mike, I had the “missing input in order…” error last week and I’m still learning ODM, but

which specific software are you using? Are you using webodm or ODM to process (create the meshing, orthophotos, etc) the files ?

If you’re just using ODM, are you installing it natively, or are you using the docker image?

Regardless of those answers, what worked for me

If you’re using the docker image, I had to explicitly add the line -v "$(pwd)/gcp_list.txt:/code/gcp_list.txt" \ to my docker command; (I put the gcp_list.txt in both the images directory as well as the directory where I ran the docker command from, to be safe).

Nice to meet you thanks for the reply.

I am using WebODM in a docker box on a windows 10. I dont know much about the adding the line you provided I use the WebODM manager to start WebODM I am not experienced command line stuff. I have scoured the gcp_list.txt for extra spaces or dashes. I think its clean.

I tried reprocessing with NodeODM with same results. ? I appreciate your suggestions I’ll keep you posted on my process


1 Like