Missing input in order to use GCP for georeferencing ODM 0.9.1 GCP Processing

I have just switched to ODM 0.9 and process few datasets with GCP , All goes successfully completed. But with odm georeferencing logs says - “Missing input in order to use GCP for georeferencing. Using EXIF data instead”
Same dataset works with ODM 0.4 and ODM 0.5.

I noticed that odm_georeferencing stage not taking gcp file as input while in older version gcp_list.txt file was passing to “build/bin/odm_georef” comand.

odm-v0.9/stages/odm_georeferencing.py

Operating System - Ubuntu 16.04 LTS
ODM Version - 0.9.1
Command - odm0.9/run.sh --project-path $EXECUTIONDIR --gcp $PROJEXECUTIONDIR/gcp.txt --end-with odm_orthophoto $Dataset-id --dsm

Let me know if anything got changed in 0.9 for GCP processing.

Thanks

odm_georef is no longer in charge of computing the GCP alignment; that task has been moved to OpenSfM, which allows us to take in consideration an arbitrary number of GCPs (instead of using just the best triplet, like odm_georef did).

So long as odm_georef is being called with the -inputTransformFile parameter, you should be fine. That warning in the log should probably be removed (open a PR?)

Thanks @pierotofy for this information. Didn’t find any documentation there so i was not sure on that.
I don’t have good coding skills in python , Will take a look if i can manage that.
Don’t see anything related to gcp in logs, Is there any way i can see logs how GCP compute with opensfm for troubleshooting any issue. Like previously odm_georef logs were created for the same.