Micasense Stack Images unable to open / exif issue?

Hello, I have been successfully processing individual band micasense multispectral imagery, and have been wanting to try processing already aligned stack images. I’m hoping that this might cut down on processing times or achieve a better alignment. However, I have never been able to use my stack images and am curious what is wrong about them. I’m including a link to a google drive folder containing 5 stack images which I’ve tried to copy the correct exif and xmp data to, along with the full log from running them.

This issue has persisted through every version of odm that I have tried it with, and I’m assuming that the problem is with my images. Below is a snippet of the relevant error message.

PIL.UnidentifiedImageError: cannot identify image file ‘/var/www/data/ed92e8c4-9cd3-4a5a-9cf8-127bedc8b6fb/images/IMG_0008.tif’
During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/code/run.py”, line 69, in
File “/code/stages/odm_app.py”, line 83, in execute
File “/code/opendm/types.py”, line 342, in run
self.process(self.args, outputs)
File “/code/stages/dataset.py”, line 109, in process
p = types.ODM_Photo(f)
File “/code/opendm/photo.py”, line 79, in init
File “/code/opendm/photo.py”, line 255, in parse_exif_values
self.width, self.height = get_image_size.get_image_size(_path_file)
File “/code/opendm/get_image_size.py”, line 19, in get_image_size
width = img.shape[1]
AttributeError: ‘NoneType’ object has no attribute ‘shape’

1 Like

Seems like this applies:

1 Like

Thanks for the response. I think the --skip-band-alignment parameter introduced in this will definitely be useful, but I’m not even able to open up the stack images after they’re uploaded. I’ve tried using the new version from today to no effect, I’m assuming the issue is all on my end.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.