MacOS - WebODM Manager Won't Talk To Docker

After installing WebODM, it installed Docker, and I got the account set up with that. WebODM throws a Fatal error “Docker is already running”. The WebODM Manager says “Docker is installed but not communicating…” and “Launching Docker…” but after a while if it trying to load, throws another error saying “We had some issues launching Docker. Find the Docker application and start it manually, then restart WebODM Manager.”

I have done that several times with no success. It does the same thing every time. I payed for the installer as well. This is on MacOS Catalina 10.15.16. Any help is much appreciated.

1 Like

Hey @Shadowpoint :raised_hand: if you start docker manually do you get an error message? Silly question also, have you tried to reboot the computer?

Yes to both. I have restarted the computer, I have tried starting Docker first (and ran code to make sure it works…it does), then ran WebODM. I have uninstalled both programs and tried installing them in reverse order and running them in reverse order as well, and no luck. Same error messages every time.

I am not a coder, so going much further into coding is futile for me :stuck_out_tongue: Hence…I am here!

It happened to me on Mac after upgrading Docker to version 2.3.0.5.
Screenshot 2020-09-18 at 06.44.12
And then it gets stuck.
The issue is that I cannot update webodm images, otherwise I can run old containers manually from docker dashboard.

On Windows even after I upgraded Docker to version 2.3.0.5, WebOdm Manager works just fine and does not complain.
Who should be notified about this issue?
Besr regards,

1 Like

I will look into this today.

1 Like

Edit: do not downgrade! Instead, turn off the “Cloud experience” setting as indicated below.

If you downgrade docker to 2.2.0.3 does it start? https://download.docker.com/mac/stable/42716/Docker.dmg

Hey hey! It’s now retreiving objects and stuff like it’s supposed to! Thank you! I’ll reach out if anything else comes up.

1 Like

Ok, everything looks like it’s running properly, but when I go to process images, it returns with a code 1 error. Here’s the output:

This is a docker bug. Aside from downgrading, you can also turn off the “Cloud experience” option from the Docker Preferences. https://github.com/docker/for-mac/issues/4919

Edit: do not downgrade, unless you are prepared to start with a fresh installation and lose your previous data! Turn off “Cloud experience” instead

image

2 Likes

The Docker you sent does not have that option. Only “Enable experimental features”, which is turned off.

Correct; that option is only available on docker 2.3. Turn off that option if you have the newer version.

I downgraded to 2.2.0.3 (the one you sent), and I’m having that error. Is there another version I should downgrade further to?

How did you get here then? :slight_smile:

Upgrade to the latest version of docker, then you’ll find the “enable cloud experience” switch.

Ok, I updated Docker again, started WebODM and everything ran great until it threw the code 1 error again. That’s after I turned off the thing you said to turn off and restarted the program.

You’re running out of memory. Make sure to allocate more to docker: https://stackoverflow.com/questions/32834082/how-to-increase-docker-machine-memory-mac/39720010#39720010

1 Like

That FIXED IT! Thank you SO much. I was dreading having to spend hundreds of dollars to make a 2D map for my clients. This seems like an awesome solution. The support here is fantastic. Thanks again.

2 Likes

I had the same problem as Shadowpoint and did the docker downgrade from 2.3.0.5 to 2.2.0.3. I then restarted WebODM Manager, which downloaded a whole new WebODM application that installed over top of what I had before. In doing so it appears I lost all of my work/projects from before.
How do I get my projects back?
WebODM-Docker-launchingerror

These are the new containers installed…
docker-containers

This is the information from WebODM Manager after I had downgraded and tried to start WebODM…
Docker is installed, but is not communicating…
Launching docker…
Waiting for WebODM to start…
Press Start to launch WebODM
Starting WebODM…
Waiting for WebODM to start…
Starting node-odm …
Starting broker …
Starting db …
Starting worker …
Starting webapp …
e[5Ae[2K
Starting node-odm … e[31mfailede[0m
e[5B
e[4Ae[2K
Starting broker … e[32mdonee[0m
e[4Be[3Ae[2K
Starting db … e[32mdonee[0m
e[3Be[2Ae[2K
Starting worker … e[32mdonee[0m
e[2Be[1Ae[2K
Starting webapp … e[31mfailede[0m
e[1B

If you open a Terminal and type:

docker volume ls

What output do you get?

docker-ls