Linux Service missing Redis.service

Hi, I orginally posted this in WebODM, but it is really more General, so I deleted that. I hope this isn’t against guidelines.

I have WebODM running on a Ubuntu 20.04 server, appears to work fine, I placed WebODM in /opt/webodm. When I try to set up systemctl to run docker, it fails. I went into the webodm-gunicorn.service file and updated the paths, as well as the nginx file, run the commands
systemctl enable /opt/webodm/service/webodm-gunicorn.service
systemctl enable /opt/webodm/service/webodm-nginx.service

and when I try to start them I get an error, redis.service not found.

user odm is in the docker group, and the entire directory/subs all files including hidden are owned odm:odm

I know I could just place ./webodm.sh start into rc.local, but I would really like to manage it through systemctl.

Are there other service files I need to change, or another service or something I need to add? I had this running on a dev server as a service, and the only thing I changed was the path from /webodm to /opt/webodm as far as I recall.

I have now also tried removing WebODM and putting it in /webodm, to no avail, I get the same error there as well.

Thanks!
SmashSE

1 Like

Maybe we need to make a redis.service file? Is there one?

There is a webodm-celery.service and a webodm-celerybeat.service file in there, and I believe that’s what starts redis, or is supposed to. But it is the same as what’s on my dev server, and it works, but it looks the same. I have also tried putting it in the exact same file path as my dev server, which is /webodm/WebODM, the subdirectory is created by git. All files are owned by odm, odm is part of the docker group, only things I wasn’t clear on is:

  • Required WebODM directory checked out to /webodm - If this means to git the WebODM folder to the root, then rename it to /webodm, I tried that, and it didn’t work, and that isn’t how it is on my working dev server.

  • Requires that a Python 3 environment is used at /webodm/python3-venv
    No idea what this is.

But it is really peculiar since it works on one machine, installed a couple weeks ago, and not on the new install I did yesterday.

OK, I take it back, I don’t think my dev server does work for services, looks like I actually started it with & in the command and logged out…

Maybe this is just something that doesn’t work?

1 Like

Yeah, I’m not sure. I’ve never tested this way of running it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.