Launching WebODM issues

Have recently installed but failing to run the WebODM - I have updated my Firewall settings to allow the programme to run to no avail. Log is as shown:

“Booting WebODM 1.9.14 build 64…”
“Trying to connect to NodeODM localhost:29301…”
“Attempt 0 failed, retrying…”
“nodeodm: info: Authentication using SimpleToken\r\n”
“nodeodm: info: Listening on 0.0.0.0:6367 UDP for progress updates\r\n”
“nodeodm: info: No tasks dump found\r\n”
“nodeodm: info: Checking for orphaned directories to be removed…\r\n”
“nodeodm: info: Server has started on port 29301\r\n”
“Trying to connect to NodeODM localhost:29301…”
“Connected to NodeODM 2.2.0”
“redis-server: . \n .-__ ''-._ \n _.- . . ‘’-._ Redis 3.2.100 (00000000/0) 64 bit\n .- .-```. ```\\/ _.,_ ''-._ \n ( ' , .-` | `, ) Running in standalone mode\n |`-._`-...-` __...-.-.|’_.-'| Port: 29379\n | -. ._ / _.-' | PID: 14880\n -._ -._ -./ .-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | http://redis.io \n -._ -._-..-’.-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | \n -._ -._-..-’_.-’ _.-’ \n -._ -..-’ _.-’ \n -._ _.-' \n -..-’ \n\n[14880] 21 Jun 13:45:47.925 # Server started, Redis version 3.2.100\n[14880] 21 Jun 13:45:47.925 * The server is now ready to accept connections on port 29379\n”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: exited with code 3221225595”
{}
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 0 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 1 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 2 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 3 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 4 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 5 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 6 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 7 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 8 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“Attempt 9 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 3221225595”

1 Like

Welcome!

Sorry for the trouble! Could you please start with giving me a bit more information about your system?

For instance:

  1. Operating System and Version
    eg: Windows 11, MacOS 15.1, Ubuntu Linux 20.04LTS, etc…
  2. Hardware Specifications
    eg: 32GB RAM, i7-6700k, NVIDIA GTX 1050TI OC, 1TB SSD, etc…
  3. WebODM Install Method
    eg: Native installer, Docker, Snap, GitHub download, compiled from source
  4. WebODM/ODM Version
    eg: WebODM v1.9.14 Build 63, ODM v2.8.6, etc…
  5. Procesing Node
    eg: Automatic, Lightning, local (node-odm-1), etc…
  6. Screenshots demonstrating the issue/behavior/error messages

Good Afternoon,

  1. Windows 11 Home
  2. 8GB RAM, Intel i5 10210U CPU, Aspire 5
  3. Native Installer (followed Web Link to download)
  4. WebODM Version 1.9.14 Build 64
  5. Assume Automatic
  6. Attached

1 Like

Do you have an antivirus software installed by any chance?

1 Like

I do yes - but have gone into the settings to ensure that the software has not been blocked/disabled etc

1 Like

Sometimes AV software interferes with the launch of the WebODM (and disabling / whitelisting it does not do the trick). You could try to whitelist the psql executable as well, or temporarily disable the AV software, but it’s hard to say if this will work.

1 Like

If Piero’s advice doesn’t get you sorted, reach out to [email protected] so we can schedule a Remote Support session and we can troubleshoot further.

After installing new builds I find that sometimes it fails to start, but the old IT trick of turning your computer off then on usually fixes the problem for me.

1 Like