Issues Running WebODM Locally

Hey everyone! CesiumJS dev here (and complete WebODM noob). I’m working to fix the Cesium ion plugin for WebODM. The following thread does a nice job illustrating the first issue that I am trying to tackle:

However, I am struggling to get my development environment setup. I have cloned WebODM, and added the deprecated cesiumion plugin to the coreplugins folder. However, after I run .\ start, I navagate to http://localhost:8000/admin/app/plugin/, I get the following error.

This site can’t be reached. localhost refused to connect.

Any suggestions? Not sure if this first issue is actually related to the cesiumion plugin, but I’ve got to start somewhere! Thanks in advanced for the guidance and support :grinning: :pray:


1 Like

Welcome, Sam!

Thanks for helping us maintain and fix this plugin!

Could you please start with giving me a bit more information about your system?

For instance:

  1. Operating System and Version
    eg: Windows 11, MacOS 15.1, Ubuntu Linux 20.04LTS, etc…
  2. WebODM Install Method
    eg: Native installer, Docker, Snap, GitHub download, compiled from source
  3. WebODM/ODM Version
    eg: WebODM v1.9.12 Build 55, ODM v2.8.0, etc…

Hi, welcome! :wave: thanks for helping us fix the plugin!

Make sure you pass --dev to the start command:

./ start --dev

This will actually pick-up the changes to the coreplugins folder.

The cannot connect to localhost is a bit strange, you can access the login screen, dashboard, etc. but just not the plugin’s page? Can you post a copy of your terminal output?

1 Like

Hi guys,

Yup! Happy to provide some more information about my system:

  1. Windows 11
  2. I cloned WebODM from GitHub
  3. To the best of my knowledge, I cloned the most recent version from GitHub

I am going to include a quick screen grab of what I have done so far. Hopefully this helps.


I wonder if there is something very simple that I am missing or forgetting here.


1 Like


I have this in my .wslconfig:


Can you see if this helps with the port forwarding from Docker/WSL2?

It looks like you’re running this in powershell?

You need to run this in a bash shell (for example, from git-bash).


Hi everyone,

Once again, thank you @Saijin_Naib and @pierotofy for the support! I really apricate your timely responses. I tried running the command ./ start from a bash terminal, and was able to get WebODM running locally :grinning:

I also tried running the command ./ start --dev. This seems to have started some kind of a build process, which is taking a long time to complete (10+ minutes). Is this normal?

Eventually, the build process did complete, and I was able to begin experimenting with the cesiumion plugin that I added to coreplugins. I was even able to make modification to files in the cesiumion folder, such as app.html, and see the results in my locally hosted version of WebODM. Thank you both so much for the guidance!!

All the best,


So excited Piero got you sorted.

Looking forward to seeing what you make!

Hi @pierotofy,

One quick follow up question regarding this comment:

Will using the setting ./ start --dev rebuild the jsx code in my plugin, or is there a separate command that I should run to do that?


1 Like

You need a separate command (webpack --watch), or you can let WebODM handle that via:

./ start --dev --dev-watch-plugins
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.