Issues attempting to reinstall WebODM

Hi all,

I still haven’t got my head around how WebODM works and I think that’s what has caused the problem I’m in.

Until today I have been processing images through WebODM just fine. Had a memory error message come up and the node kept constantly restarting thereafter. Couldn’t find a way to fix have looking through the forums and github etc. So I deleted the node through docker thinking I could easily make a new node through the host. Couldn’t work out how.

Long story short I’ve tried to completely uninstall WebODM and now following the installation again but I’m stuck on gitbash with the text saying:

$ ./webodm.sh start
Checking for docker… OK
Checking for docker-compose… OK
Starting WebODM…

Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
SSL: NO
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
Pulling db (opendronemap/webodm_db:)…

Trying down and start again and I get and am stuck at:

$ ./webodm.sh start
Checking for docker… OK
Checking for docker-compose… OK
Starting WebODM…

Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
SSL: NO
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
Pulling broker (redis:)…
Docker Compose is now in the Docker CLI, try docker compose up

latest: Pulling from library/redis

Think I just want to know how to completely remove WebODM from my computer so that I can install it again without issues. As you can tell I’m not extremely techy. Really got my head spinning.

Thanks,
Omar

1 Like

Welcome!

Sorry you’re having a hard time.

Try this:

1 Like

Hi Saijin,

Thanks for the quick response.

Have followed what you attached and have attempted to install it once again but it is still stuck at the same location. Had a look at another topic where someone was stuck at the same place and it was suggested it could be a internet connection issue? Internet here isn’t great so could try somewhere better and see if it works there.

1 Like

Ah, that’s very possible.

The first pull from Docker is a lot of data, so if your connection is slow or drops at all, it can kind of jam things up.

1 Like

Hi Saijin,

Managed to go to somewhere with a slightly better connection and with time I managed to get WebODM running!

However, I’ve now come across an issue with the login. This time I did not see anywhere to put in my username and password when setting up WebODM and trying to log into WebODM with my previous username and pass doesn’t work (obviously?).

Tried running:
./webodm.sh start && ./webodm.sh resetadminpassword newpass

But it comes up with:
$ ./webodm.sh start && ./webodm.sh resetadminpassword newpass
-bash: ./webodm.sh: No such file or directory

Tried downloading Cygwin and running the command there but no success- same message.

Thanks,
Omar

1 Like

Silly question, but did you make sure your Current Working Directory in your terminal was actually where the webodm.sh script was located?

For me that is this path: /home/alpine/Sources/WebODM/webodm.sh
image

If I try to execute those commands not in this directory, they will fail exactly as yours did.

1 Like

Hi Saijin,

Hope this question doesn’t come across as a bit stupid but how do check that the current working directory in my terminal is where the script is? If it’s not in the same location, how do I change it so that it is?

Thanks,
Omar

1 Like

So, you use ls to list whats in a directory. You use cd to change directory

So, if your terminal shows you something like:
[email protected] / that means you’re likely at your user’s home folder.

If you ls it, it should show you stuff. Maybe folders like Desktop, Documents, Downloads, etc if your distro is XDG compliant.

If you want to go up, you cd .. to go up one folder.

You need to cd to where your script is. So for me, in my home directory, that would look like this:
cd ~Sources/WebODM/

That tilde, ~, is a path expansion character that stands in for the path to my home directory. So, it really means /home/alpine/

Then I could just run the script:
./webodm.sh start

2 Likes

Hi Saijin,

Just an update. Yep, you were right that I wasn’t in the correct directory, I it tried again but it loaded the same error message William was getting in this thread: Reinstall or reset password

Tried the update method you posted in the linked thread but the internet here isn’t great and it came up with an error before it could fully update- issue was not resolved. Have completely removed webODM again and will try to install it again once I’m somewhere with good internet… hopefully tomorrow. Will keep you updated.

Thanks,
Omar

1 Like

Okay so, I just wrote out a whole essay about what I’ve tried after it didn’t work after installing webODM again. After the install, going to localhost:8000 would still ask me to put in my old log in details and trying the resetpass command in my terminal still didn’t work.

Didn’t think this was an issue but my docker has been out of date so as a last resort I updated it to the latest version. Literally just before I pressed send on the little essay I wrote out I went to check localhost one more time after looking at download guides online.

Never been so happy to see confetti since being 10 years old.

It now came up with an option to put in new log in details and it looks like it’s working. Logged in but haven’t tried anything else just yet.

I thought it was something to do with my terminal because when I tried to put in 1s it was coming up with bash: 1s command not found.

Would docker not being up to date actually have caused this issue? I haven’t changed anything else apart from updating it.

Thanks Saijin for your help!!

1 Like

And resetadminpassword now works too!

2 Likes

I hate fonts without serfis :roll_eyes: Not your fault, just a thing that unfortunately happens a lot, espcially with fonts that don’t cross the zero out so you can easily distinguish it from the capital letter O.

That is ls, as in list.

That’s the joke here, but it isn’t funny because someone would absolutely use this :grimacing:
https://twitter.com/The_Tin_Hat/status/1448084078016688128?s=20

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.