Issue with project path

Hello,

I’m having trouble for selecting the project path. I tried running

winpty docker run -ti --rm -v c:/projects:/datasets/code opendronemap/odm --project-path /datasets

at first, but got “docker: Error response from daemon: invalid mode: \Program Files\Git\datasets\code.”

Following a tip I saw on this forum, I tried (to avoid excessive ‘:’)

winpty docker run -ti --rm -v /c/projects:/datasets/code opendronemap/odm --project-path /datasets

but I’m now getting the following issue:

Alexandre@DESKTOP-***** MINGW64 ~
$ winpty docker run -ti --rm -v /c/projects:/datasets/code opendronemap/odm --project-path /datasets
Unable to find image ‘opendronemap/odm:latest’ locally
latest: Pulling from opendronemap/odm
a70d879fa598: Pull complete
c4394a92d1f8: Pull complete
10e6159c56c0: Pull complete
36b9fde8f05e: Pull complete
b8e51b3aee79: Pull complete
5c07d92ee84c: Pull complete
acdae07bc669: Pull complete
Digest: sha256:9371f46c655c92f44b540ca773ab95c4dd07b3c30b2f5e70bb16f80a4af01b67
Status: Downloaded newer image for opendronemap/odm:latest
[INFO] Initializing ODM - Tue Apr 20 21:01:22 2021
[INFO] ==============
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 5
[INFO] depthmap_resolution: 640
[INFO] dsm: False
[INFO] dtm: False
[INFO] end_with: odm_report
[INFO] fast_orthophoto: False
[INFO] feature_quality: high
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 18
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: code
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 5
[INFO] pc_classify: False
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: C:/Program Files/Git/datasets
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: None
[INFO] resize_to: 2048
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_report: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: False
[INFO] ==============
[WARNING] Directory code does not exist. Creating it now.
[INFO] Running dataset stage
[INFO] Loading dataset from: /code/C:/Program Files/Git/datasets/code/images
Traceback (most recent call last):
File “/code/run.py”, line 68, in
retcode = app.execute()
File “/code/stages/odm_app.py”, line 83, in execute
self.first_stage.run()
File “/code/opendm/types.py”, line 319, in run
self.process(self.args, outputs)
File “/code/stages/dataset.py”, line 93, in process
files, rejects = get_images(images_dir)
File “/code/stages/dataset.py”, line 61, in get_images
entries = os.listdir(in_dir)
FileNotFoundError: [Errno 2] No such file or directory: ‘/code/C:/Program Files/Git/datasets/code/images’

It does nothing except creating a folder named “projects;C” in C:\ each time it runs (even if this folder already exists) which doesn’t seem correct at all.

I tried with paths in Users/ too, same issue. The previous tries came from a fresh docker environment (docker desktop, win10).

Thank you for reading and helping.

1 Like

I’m no docker expert, but try putting your images in a folder called images.

Here’s what my docker call looks like on macOS. OS shouldn’t matter here, ODM still has to be able to find your files.

docker run -ti --rm -v /Users/.../.../datasets:/datasets opendronemap/odm --project-path /datasets project

And my images are located in .../datasets/project/images/some.jpg

1 Like

Well I already tried it, but just thought about the fact that I was using git bash, so had to use winpty (not like your example). Well, it worked in docker quickstart, so I guess that was the issue.

Thank you for making me think about this^^

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.