Issue : running gdal_proximity.py nadiral photos

Hello everybody :slight_smile: I tried to perform a processing of 109 photos. The photos are nadiral photos of an olive grove in Italy. I state that I have already done more completed similar jobs processing went fine until it gave me this error:

#!/usr/bin/env python3

import sys

import osgeo.utils.gdal_proximity as a convenience to use as a script

from osgeo.utils.gdal_proximity import * # noqa
from osgeo.utils.gdal_proximity import main
from osgeo.gdal import deprecation_warn

deprecation_warn(‘gdal_proximity’, ‘utils’)
sys.exit(main(sys.argv))

[INFO] auto_boundary: True
[INFO] boundary: {}
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: True
[INFO] copy_to: None
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: True
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 2.0
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: ultra
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: True
[INFO] matcher_neighbors: 0
[INFO] matcher_type: flann
[INFO] max_concurrency: 8
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 10000
[INFO] name: 79e4d524-743c-4179-b185-0b29e2ab64d5
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 2.0
[INFO] pc_classify: True
[INFO] pc_copc: False
[INFO] pc_csv: False
[INFO] pc_ept: True
[INFO] pc_filter: 2.5
[INFO] pc_geometric: False
[INFO] pc_las: False
[INFO] pc_quality: ultra
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_tile: True
[INFO] primary_band: auto
[INFO] project_path: C:\WebODM\resources\app\apps\NodeODM\data
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: None
[INFO] resize_to: 2048
[INFO] sfm_algorithm: incremental
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_orthophoto: False
[INFO] skip_report: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: True
[INFO] ==============

[INFO] running gdal_translate -co NUM_THREADS=8 -co TILED=YES -co BIGTIFF=IF_SAFER -co COMPRESS=DEFLATE --config GDAL_CACHEMAX 39.25% “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\merged.vrt” “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\tiles.tif”
Input file size is 19075, 18245
0…10…20…30…40…50…60…70…80…90…100 - done.
[INFO] Starting smoothing…
[INFO] Smoothing iteration 1
[INFO] Completed smoothing to create C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.tif in 0:05:43.573984
[INFO] Completed dsm.tif in 0:20:22.142708
[INFO] Cropping C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.tif
[INFO] running gdalwarp -cutline “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_georeferencing\odm_georeferenced_model.bounds.gpkg” -crop_to_cutline -co TILED=YES -co COMPRESS=DEFLATE -co BLOCKXSIZE=512 -co BLOCKYSIZE=512 -co BIGTIFF=IF_SAFER -co NUM_THREADS=8 “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.original.tif” “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.tif” --config GDAL_CACHEMAX 39.5%
Creating output file that is 18845P x 18003L.
Processing C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.original.tif [1/1] : 0Using internal nodata values (e.g. -9999) for image C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.original.tif.
Copying nodata values from source C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.original.tif to destination C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.tif.
…10…20…30…40…50…60…70…80…90…100 - done.
[INFO] Cropping C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.tif
[INFO] running gdalwarp -cutline “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_georeferencing\odm_georeferenced_model.bounds.gpkg” -crop_to_cutline -co TILED=YES -co COMPRESS=DEFLATE -co BLOCKXSIZE=512 -co BLOCKYSIZE=512 -co BIGTIFF=IF_SAFER -co NUM_THREADS=8 “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.original.tif” “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.tif” --config GDAL_CACHEMAX 39.2%
Creating output file that is 18845P x 18003L.
Processing C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.original.tif [1/1] : 0Using internal nodata values (e.g. -9999) for image C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.original.tif.
Copying nodata values from source C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.original.tif to destination C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.tif.
…10…20…30…40…50…60…70…80…90…100 - done.
[INFO] Computing euclidean distance: C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.euclideand.tif
[INFO] running gdal_proximity.py “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.unfilled.tif” “C:\WebODM\resources\app\apps\NodeODM\data\79e4d524-743c-4179-b185-0b29e2ab64d5\odm_dem\dsm.euclideand.tif” -values -9999.0

1 Like

Did the Task processing fail?

Also, can you please remove --ignore-gsd from your Task options in the future? This flag is pretty dangerous and very often leads to random failures and crashes.

No processing didn’t fail but odm don’t work any more.
I tried to clear all memory reinstall webodm but i find the same issue.
Usually webodm work fine. I cant understand how it is possibile.
I have same problem with an other similar dataset.
It looks like that it isn’t a problem of dataset or setting.
I usually take photos at 50 m 75% front overlap and 65% side overlap with a gimbal pitch of 5°, usually web odm gives to me great results.

I have the folder of process in node data
I tried to restart it from calculating dem but web odm restart from a new pipeline and data

1 Like

What version of WebODM are you using?

When you start it, the blue splash screen will have the version and build on the bottom right.

Last update bulid 61
I want to try with an older version.

1 Like

We don’t archive prior versions since we’re a Rolling Release, unfortunately.

Reach out to [email protected] with your MYSXXXXXX-XXXX-XXXXX order confirmation number and I can schedule a remote support/troubleshoot appointment with you to see what’s going on, and see if we can gather data to fix this.

I will try with the version that i downloaded when i bought the windows version. If it dosen’t work i will ask support to uav4geo

1 Like

Don’t use --split or --dem-euclidean-map as a workaround; it’s a bug that has been fixed with Programmatic gdal_proximity call · OpenDroneMap/[email protected] · GitHub but hasn’t been released with WebODM native (yet).

2 Likes

Thanks a lot
the bug is fixed
Grazie tante ho fatto come dici e ho risolto il problema
Complimenti per il vostro lavoro :slight_smile:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.