Issue adding MicMac to WebODM

Hello everyone,

I’ve been using WebODM for about a month now and just found out about the MicMac node which seems to offer higher resolution orthos.

The announcement (here) says that

"Existing WebODM users (using docker) can get up and running with MicMac by simply typing:

./webodm.sh update
./webodm.sh restart --with-micmac"

So far I have just been using the WebODM manager and interface in my browser. I’m not sure where I should be typing this command. Apologies if this is a silly question. If I have to use Docker or the Open Shell in the WebODM manager please let me know.

Hey @Moug :hand: if you’re using WebODM Manager, I’d recommend to go to C:\WebODM Manager and replace the second line of “start.bat” (right click – Edit) with the following:

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml -f docker-compose.nodemicmac.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml -f docker-compose.nodemicmac.yml up

Press “Update”, then from WebODM’s interface go to Processing NodesAdd New and type:

Hostname: node-micmac-1
Port: 3000
Label: MicMac

Followed by Save.

2 Likes

Running my first set with it now, thank you so much!

2 Likes

How could be enabled Micmac on native install Ubuntu 16.04?
Thank you .

At the moment, using docker.

curl -fsSL https://get.docker.com -o get-docker.sh
sh get-docker.sh
docker run -d -p 3001:3000 dronemapper/node-micmac

Then add a node with host localhost and port 3001.

1 Like