IOError: [Errno 2] No such file or directory:

Hi guys,
I have been trying to do orthomosaic model with a camera that doesn’t have gps. The first data set I used worked quite well but the positioning of the camera I missed large sections of the floor. With the new data set i’m now getting this issue -
IOError: [Errno 2] No such file or directory: u’/var/www/data/97d4f3ae-83ce-4112-a51a-9e174599b666/opensfm/features/DJI_0224.jpg.features.npz

The out put is below, I’m not sure how to properly understand what its telling me, but the error seems to me that this is the issue. I have been trying to find how to fix this but i have had no luck. I am running webodm on manjaro 18 os with 32Gb of ram and 64Gb of swap mem. Thank you for any help.

Screenshot_20200210_034210

Screenshot_20200210_034121

Screenshot_20200210_034054

Screenshot_20200210_034019

Screenshot_20200210_033951

Screenshot_20200210_033932

Screenshot_20200210_033914

Screenshot_20200210_033853

Screenshot_20200210_033818

Screenshot_20200210_033719

I worked it out, I took out the offending image and then it happened again. When it happened a third time I looked at the photos and found they were all sky and some had the sun smack bang in the middel. I when through the data set and deleted all simaler photos and now it works.

3 Likes