Invalid camera issue in MVE part of ODM, orthophoto is incomplete

I’m running ODM via Docker on an AWS EC2 server with Ubuntu 18.04 operating system, 32 GB RAM and 60 GB disk space. This sizing usually works for me.

The images in the dataset are created with a Parrot Anafi drone. Usually this works well, I’ve done that a couple of times before, also for two other datasets I created on the same day for different fields with the same drone, one slightly smaller and one a bit bigger dataset.

For this dataset the ODM process completes, but it skips most of the images with an “invalid camera” issue in mve part.

Also, the message “INFO: some images can not be added” appears multiple times in the opensfm part of the process.

Does anyone know how this can be resolved?

How to reproduce:
I used this command to start the process:
sudo docker run -ti --rm -v /home/ubuntu/data:/datasets/code opendronemap/odm --project-path /datasets --resize-to 4000

Link to my dataset (130 images):

Here‘s a link to the console output:

Tuned parameters:
resize-to parameter set to 4000 (I understood that default is 2048 and 4000 would result in a better orthophoto resolution)

I’m running into the same issues, and I’ve tried on two machines: one running WebODM and the other running ODM with CLI. I know the images are good, because they’ve been able to process through both DroneDeploy and MapsMadeEasy without any issues.