Installation - unable to connect to


I’m trying to install WebODM using the WebODM Installer. The first issue was it wouldn’t automatically download docker so I did this myself. When I launch WebODM it begins the process of cloning…see screen print.

…but is unable to connect to guthub and times out… see screen print.

What am I doing wrong?

I’m running Catalina version 10.15.7 on an iMac (27-inch, Late 2013) with 16GB of RAM. The network connection is fine.

1 Like

I did copy and run the installer to the application folder.

1 Like


Sorry you’re having trouble with the installer.

Do you have any sort of Anti-Virus running on your Mac?

Additionally, did MacOS prompt you to approve the software or anything else like that during the initial setup?

Thank you.

No virus software is running. The first time I opened the installer by double clicking the icon the OS wouldn’t allow it to open. I right clicked the icon and selected open, I think this dilong box gave me a third option of ‘open anyway’ which I clicked.

I had the firewall running, I’ve switched it off but still getting the same issue.

I’m using Docker Desktop Version 3.4.0 (

1 Like

When did you download the installer? I wonder if we have not released an updated version since then.

Try re-downloading it again from the link in your email, and reinstalling.

Earlier today. I’ll delete everything and try again.

1 Like

Let us know what happens!

Docker Desktop should also be at v3.5.0 as of today:

I’ve downloaded WebODM Manager again and the latest release of docker (v3.5.0 )

I still get the same error. (sorry)

When I ran the command line ‘docker run -d -p 80:80 docker/getting-started’

I got this… ( I may have been in the wrong directory)

Unable to find image ‘docker/getting-started:latest’ locally

latest: Pulling from docker/getting-started

540db60ca938: Pull complete

0ae30075c5da: Pull complete

9da81141e74e: Pull complete

b2e41dd2ded0: Pull complete

7f40e809fb2d: Pull complete

758848c48411: Pull complete

23ded5c3e3fe: Pull complete

38a847d4d941: Pull complete

Digest: sha256:10555bb0c50e13fc4dd965ddb5f00e948ffa53c13ff15dcdc85b7ab65e1f240b

Status: Downloaded newer image for docker/getting-started:latest


MJP3:~ matthewjones$ docker run -d -p 80:80 docker/getting-started


docker: Error response from daemon: driver failed programming external connectivity on endpoint bold_buck (b1a03200863186e36df6f2fc220226fa12615488a440743435ccc510143b26b7): Bind for failed: port is already allocated.

MJP3:~ matthewjones$

Have you tried rebooting? If I’m not mis-reading the log entry you posted, something might be occupying the port docker wants to use.

Tried rooting but no luck. Do I need to create a specific container in Docker?

This is what I have.

1 Like

You can likely safely remove those two getting-started containers.

Try this approach for now:
Follow the instructions to add the WebODM container manually:

That process is complete… see below, I still get the same issue though. Is there another step?

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit

MJP3:~ matthewjones$ docker pull opendronemap/webodm_webapp

Using default tag: latest

latest: Pulling from opendronemap/webodm_webapp

345e3491a907: Pulling fs layer

57671312ef6f: Pull complete

5e9250ddb7d0: Pull complete

0531fa089a3b: Pull complete

b0626602e995: Pull complete

338f8a9790dd: Pull complete

a834eac42cd7: Pull complete

aa8dac71d97f: Pull complete

b62de49daa07: Pull complete

69d629621af8: Pull complete

d5b6c44c8da7: Pull complete

82c287711c66: Pull complete

8b4764d3324f: Pull complete

97451a3108e2: Pull complete

5ec3af4b945b: Pull complete

8f372892e1b1: Pull complete

eeb8aa538b49: Pull complete

59e238210f7a: Pull complete

5032846c6c9d: Pull complete

fe5077cb4104: Pull complete

45d98f1425e5: Pull complete

cfa3457cc849: Pull complete

72991cc8975a: Pull complete

2525aadddc30: Pull complete

Digest: sha256:0ea449832f4c6f02b890521e3535eb93b62a9416985698eff0899939ccf33986

Status: Downloaded newer image for opendronemap/webodm_webapp:latest

1 Like

Which same issue? The port being blocked or WebODM Manager not being able to start it?

Have you rebooted after setting this all up?

I’ve tried rebooting. I don’t think port 80 is blocked. I’ve looked on activity monitor and it’s not is use.

When I run the WebODM manager I still get the error no route to host.

When I run the opendronemap/webodm_webapp image from docker

This is what it does…

VOLUME [/webodm/app/media] 0 Bytes
1 RUN /bin/sh -c rm /webodm/webodm/ # buildkit 0 Bytes
2 RUN /bin/sh -c apt-get clean && rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/* # buildkit 0 Bytes
3 RUN /bin/sh -c apt-get remove -y g++ python3-dev libpq-dev && apt-get autoremove -y # buildkit 1.45 MB
4 RUN /bin/sh -c python translate build --safe # buildkit 538.17 KB
5 RUN /bin/sh -c python rebuildplugins # buildkit 78.94 MB
6 RUN /bin/sh -c python collectstatic --noinput # buildkit 29.25 MB
7 RUN /bin/sh -c echo UTC > /etc/timezone # buildkit 4 Bytes
8 RUN /bin/sh -c npm install --quiet -g [email protected] && npm install --quiet -g [email protected] && npm install --quiet && webpack --mode production # buildkit 219.6 MB
9 WORKDIR /webodm 0 Bytes
10 RUN /bin/sh -c npm install --quiet # buildkit 122.45 MB
11 WORKDIR /webodm/nodeodm/external/NodeODM 0 Bytes
12 RUN /bin/sh -c ln -s /webodm/nginx/crontab /var/spool/cron/crontabs/root && chmod 0644 /webodm/nginx/crontab && service cron start && chmod +x /webodm/nginx/ # buildkit 241 Bytes
13 ADD . /webodm/ # buildkit 68.77 MB
14 RUN /bin/sh -c pip install -r requirements.txt # buildkit 307.81 MB
15 ADD requirements.txt /webodm/ # buildkit 1.51 KB
16 RUN /bin/sh -c update-alternatives --install /usr/bin/python python /usr/bin/python2.7 1 && update-alternatives --install /usr/bin/python python /usr/bin/python3.8 2 # buildkit 11.07 KB
17 RUN /bin/sh -c apt-get -qq update && apt-get -qq install -y --no-install-recommends python3 python3-pip python3-setuptools python3-wheel git g++ python3-dev python2.7-dev libpq-dev binutils libproj-dev gdal-bin python3-gdal nginx certbot grass-core gettext-base cron postgresql-client-12 gettext # buildkit 690.56 MB
18 RUN /bin/sh -c apt-get -qq update && apt-get -qq install -y nodejs # buildkit 71.39 MB
19 RUN /bin/sh -c wget --no-check-certificate -O /tmp/ && bash /tmp/ # buildkit 21.77 KB
20 RUN /bin/sh -c apt-get -qq update && apt-get -qq install -y --no-install-recommends wget curl # buildkit 3.08 MB
21 RUN /bin/sh -c add-apt-repository -y ppa:ubuntugis/ubuntugis-unstable # buildkit 132.69 KB
22 RUN /bin/sh -c apt-get -qq update && apt-get install -y software-properties-common tzdata # buildkit 165.58 MB
23 WORKDIR /webodm 0 Bytes
24 RUN /bin/sh -c mkdir /webodm # buildkit 0 Bytes
25 ENV PROJ_LIB=/usr/share/proj 0 Bytes
26 ENV PYTHONPATH=:/webodm 0 Bytes
28 MAINTAINER Piero Toffanin [email protected] 0 Bytes
29 /bin/sh -c #(nop) CMD [/bin/bash] 0 Bytes
30 /bin/sh -c mkdir -p /run/systemd && echo ‘docker’ > /run/systemd/container 7 Bytes
31 /bin/sh -c [ -z $(apt-get indextargets) ] 0 Bytes
32 /bin/sh -c set -xe && echo ‘#!/bin/sh’ > /usr/sbin/policy-rc.d && echo ‘exit 101’ >> /usr/sbin/policy-rc.d && chmod +x /usr/sbin/policy-rc.d && dpkg-divert --local --rename --add /sbin/initctl && cp -a /usr/sbin/policy-rc.d /sbin/initctl && sed -i 's/^exit./exit 0/’ /sbin/initctl && echo ‘force-unsafe-io’ > /etc/dpkg/dpkg.cfg.d/docker-apt-speedup && echo 'DPkg::Post-Invoke { rm -f /var/cache/apt/archives/.deb /var/cache/apt/archives/partial/.deb /var/cache/apt/.bin
33 /bin/sh -c #(nop) ADD file:5c44a80f547b7d68b550b0e64aef898b361666857abf9a5c8f3f8d0567b8e8e4 in /
1 Like

Seems a network problem. Docker seems to work fine. Can you run from a terminal:

git clone


If not, something on your network (either a firewall on your computer, or other software on your modem/switch) is preventing the connection to Try disabling VPN if you’re using it or connect from a different network (can you use a mobile hotspot temporarily?).


The GIT command seemed to run okay.

MJP3:~ matthewjones$ git clone GitHub - OpenDroneMap/WebODM: User-friendly, commercial-grade software for processing aerial imagery. 🛩

Cloning into ‘WebODM’…

remote: Enumerating objects: 13618, done.

remote: Counting objects: 100% (705/705), done.

remote: Compressing objects: 100% (322/322), done.

remote: Total 13618 (delta 358), reused 624 (delta 332), pack-reused 12913

Receiving objects: 100% (13618/13618), 105.79 MiB | 3.99 MiB/s, done.

Resolving deltas: 100% (8712/8712), done.

MJP3:~ matthewjones$

1 Like

Tethered to my mobile and it’s installed. Thank you both for your help and patience. I would have diagnosed that,




Glad you’re resolved and Piero was able to save the day!


Appreciate your help. My internet provider is Virgin Media btw

I’ve already produced a decent orthomosaic map. Looking forward learning more and excited about what it WebODM can do.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.