Installation of webodm using The Missing Guide

I’m a newbie to this, and am having issues just installing everything in the correct order, following the instructions in The Missing Guide. Apparently, since the publishing of The Missing Guide, some components have been moved in the apps, and I’ve even found where text is suggested to be written, where it shouldn’t. I’m on one of the last steps for install on Windows and cannot get past this.

Is there a place where there are updates to The Missing Guide are kept?

Here’s where I’m currently stuck. On page 24, it suggests opening Git Bash and typing: $ ./webodm.sh start
Doing that gets me an error message indicating No such file or directory

==========

Did you issue:

git clone https://github.com/OpenDroneMap/WebODM --config core.autocrlf=input --depth 1
cd WebODM
./webodm.sh start 

?

Thanks for the fast reply. Picture me as the guy in the back of the class trying to read the chapter from the day before, while the professor is going on to the new chapter.

I’m having problems with understanding the syntax…
When I type what you sent into the command line in Bash, I’m receiving more errors. I tried it all at once, then a chunk at a time, with the same results. Perhaps I’m in the wrong app or on the wrong command line?

visited this site git clone | Atlassian Git Tutorial for more reading.

Tried the first line you sent, ending just before the --config
It’s running now. Will let everyone know the next results ASAP and will make notes in my hardcopy of the Missing Guide

for some reason Bash is not liking the --config command, even though it is in the table of usable commands. Any clues?

Since I couldn’t get the --configure to run, I tried skipping ahead to the cd webodm line. Then the ./webodm.sh start command
After some time, I opened Chrome and typed the http://localhost:8000 and amazingly WebODM appeared.

1 Like

Glad it worked!

2 Likes