Installation Error: No containers to start

#1

Hi ODM folks,

I’m trying to run WebODM on macOS via Docker. I’ve followed Docker’s Docker for Mac instructions as well as the GitHub guide on setting up WebODM. But when going to run WebODM with $ ./webodm.sh start, I get this error message:

ERROR: No containers to start
ERROR: readlink /var/lib/docker/overlay2/l: invalid argument

Here is detailed step-by-step breakdown of what I’ve done:

  1. I’ve installed Docker, & as recommended in Docker for Mac documentation, I’ve tested that the installation is indeed working by running Docker’s test image with:

$ docker run hello-world

This runs and outputs a message that tells me the installation ‘appears to be working correctly.’

  1. Inside my Docker directory (which I’ve created to house everything pertaining to Docker or WebODM), I’ve run the command git clone https://github.com/OpenDroneMap/WebODM --config core.autocrlf=input --depth 1

This outputs the following:

Cloning into ‘WebODM’…
remote: Enumerating objects: 795, done.
remote: Counting objects: 100% (795/795), done.
remote: Compressing objects: 100% (688/688), done.
remote: Total 795 (delta 99), reused 478 (delta 63), pack-reused 0
Receiving objects: 100% (795/795), 56.76 MiB | 1.85 MiB/s, done.
Resolving deltas: 100% (99/99), done.

  1. Now in the WebODM subdirectory, I run the command

./webodm.sh start

This outputs the following:

Image2

  1. Then, going to http://localhost:8000 in my browser gives me a ’site cannot be reached message.’

I’ve read all the relevant documentation I could find for Docker and WebODM.
Any thoughts here on what’s going wrong would be greatly appreciated! Many thanks.

#2

I think I’ve seen this before. Try the following commands:

screen ~/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/tty
umount /var/lib/docker/overlay2
rm -rf /var/lib/docker

Then quit the Docker application (just click the whale icon on the status bar and press “Quit Docker” or “Quit”), re-open Docker, then issue ./webodm.sh restart. Does it work then?

#3

pierotofy,

Grateful for your assistance. When I run those commands this is what I get:

Image3

And still no luck with localhost in my browser

#4

Mm, for some reason the screen command (the first one) is failing, so the subsequent commands are probably not doing what they are supposed to do.

I’m not sure, but I would start by researching why you can’t connect to the ~/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/tty console.

#5

pierotofy,

It appears the the tty for screen moved to
$HOME/Library/Containers/com.docker.docker/Data/vms/0/tty

After finding this, the following commands did the trick. I’m up & running, many thanks for your assistance!

2 Likes