Initialization failed: could not create virtual machine

Hello everyone. I recently purchased the WebODM install and am having trouble getting it to initially load up. I would really appreciate it if someone could comment on my issue. This is the error I am getting:
Error creating machine: Error in driver during machine creation: Unable to start the VM: C:\Program Files\Oracle\VirtualBox\VBoxManage.exe startvm webodm --type headless failed:
VBoxManage.exe: error: VT-x is not available (VERR_VMX_NO_VMX)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole
Details: 00:00:02.313008 Power up failed (vrc=VERR_VMX_NO_VMX, rc=E_FAIL (0X80004005))
Uh oh! Check the console. Check that you have enough memory available, disk space, that your firewall is off and that you have restarted your computer. Refer to the troubleshooting section of the installation manual for more information.
I don’t think it is a firewall issue or disk space problem. I have very little RAM right now. I know I will need more when I start processing image data and have ordered 16 GB to put in at a later date. I was unsure how much I would require just to get this thing loaded up and ready to accept images. Any help would be great. Thanks.

1 Like


Looks like VT-x are turned off in your BIOS/UEFI Firmware, or simply not available on your platform.

Can you please post exactly what the specs of your machine are?


Thanks for the Welcome and quick response Saijin! Here are my specs:
device specs

1 Like

So that platform is definitely modern enough to have it. The question then becomes if HP has a toggle enabled for it in the UEFI settings interface, which they may not since that is typically a power-user/enterprise feature (Not really, but that’s how it is marketed) and they may choose to not expose it on a consumer laptop.

You’re going to need to boot into the UEFI Settings and poke around looking for a toggle for VT-x or “Virtual Machine Support”, “Virtualization Support” or something along those lines. I don’t have the model on-hand, so I can’t do much to help, but it should be there if they support it on that platform.

Normal disclaimer when entering BIOS/UEFI:
If you don’t know what it is, don’t touch it. You can very easily make your machine not boot if you mess around in here without knowing what you’re doing.

Here’s your laptop’s user guide:

Thanks for that info. I have poked around with this before and this helps steer me in the right direction. I will post how it goes.

1 Like

Could this be the setting? If so, it was already enabled.

Yeah, that should be it.

Can you show me a screenshot of your Task Manager? It should show if Virtualization is supported on your platform and enabled for Windows:

It is also enabled.
task manager

1 Like

Any of these settings need to be changed possibly?

1 Like

No, those are all fine. Hmm… I’ll have to get back to you on what’s going on.

Ok. No hurry. I appreciate you taking your time on a Sunday afternoon (at least where I am) to help out. Thanks again.

1 Like

Can you try to make sure that Hyper-V is completely disabled? virtualbox - AMD-V is not available (VERR_SVM_NO_SVM) - Super User

If Hyper-V is running, VirtualBox cannot run.

From the link:

Try : To ensure Hyper-V is totally disabled, enter in elevated Command Prompt: bcdedit /set hypervisorlaunchtype off Run gpedit.msc and go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security, and set to Disabled. Do the same for CredentialGuard. Check Windows Defender Security Center > Device Security > Core Isolation Details, that it is turned off.

1 Like

Shouldn’t newer VirtualBox installs work alongside Hyper-V without this workaround?

They should; I suppose another thing to try would be to upgrade VirtualBox to the latest version. The version that is installed with Docker Toolbox is not the latest one.

1 Like

Anything above v6.0 is supposed to coexist easily.

I got it to download after updating Virtual Box. Thanks again for the help. I can’t wait to start using it.