Incorrect scale on my output


I’m processing my first project in WebODM and QGIS. I can’t seem to get the scale correct. All my WebODM asset layers are the same. When I add additional Layers (Google, my survey points,etc.) they are not the same scale.

The images are “off” in the WebODM View image tab as well.

This screen snips are from the WebODM view Images Tab, ( and )

Orthophoto ==> image



Could you try to reprocess your dataset, this time checking the --ignore-gsd option from the task’s presets? Just trying to rule out a possible bug.


It’s processing now, I’ll post back results


no good, same result.
Orthophoto ==>image


Mm. What drone are you using?


Sony NEX 5N - PPK geotags from Emlid Reach, Mission Planner


Do you have the ability to plot your exif values on the map?


I haven’t, I did plot the GCP’s and they are to the correct scale


Ah, then two things we should check, the above frame centers, but it sounds like this works correctly when you don’t use GCPs, but is wrong when you do use GCPs, is this correct?


No actually it plots incorrectly with or without GCP’s

I’m running another job to see if it runs correctly now.


I ran a second (new project, different set of images) job and it processed correctly.

I re checked the GCP’s. I extracted only the x,y and z from the file containing the GCP’s and Pixel locations., then plotted the coordinates. If you look on the images, the GCP’s plotted as yellow dots, they should be on the Black and white targets in the image


In this screenshot, viewing only the google earth image, without the ortho photo, you can see the GCP’s are over the correct locations,



Can you plot your image centers (what’s in the exif)?


They plotted as expected. to correct scale

I flew this in two flights upper and lower


What was the separation vertically between the flights.


Two flights, had to change batteries


If you mean time, about 10 minutes, elevation they are the same, I originally planned the mission as one flight. I realized I might run out of battery and split the mission into two halves. I moved the boundry between flights to much and lost one pass accidentlly.


when I view the model in 3D, and then apply check the Textured Model checkbox, the model is very far to the bottom, off the screen in fact.


Hmm. I think that’s the clue. What happens when you process just one half of the data (either the first or second flight)?


I tried to re run lower half. I recently discovered I was not actually using my GCP’s ( I thought all that was required was to place the GCP file in the same folder as he images and WebODM would correctly locate it) when I correctly select the GCP file I can’t successfully process.



As a part of another post, I re-ran the "bottom half images. While I still can’t get the project to process with GCP’s, I did get the scale problem fixed, evidently the missing row of images when running both flights together was jacking with the scale.

Here are the two ortho’s togerther over a google map,


Still not right, but the error now is from lack of GCP’s!