Incomplete/dotted 3D model

Well, I’ve tried a lot of different settings and only some of them show “Show Model”, but yeah, you’re absolutely right, it looks better with that. But it’s still not perfect… I’ve seen much better 3D models from ODM. I think it’s just about good settings. Thank you for your advice.


Do you think I should take more pictures from the side? I will try to move the settings up, but the max for min functions that I have been able to do is 18000, then there is a high probability that it will show me an error…

It looks like you don’t have enough memory for the highest quality settings. What are your computer details? How much virtual memory do you have on top of RAM?

Images taken at -60 will certainly improve the 3D modelling in a scene like this.

1 Like

Gordon’s analysis of your tracks file is spot on. You have two options: throw more (RAM) resources at the problem and hope you can extract more out of the data, or include more flight lines so your sidelap is higher. Over forest, I recommend as high as 83%, though you can get away with 77% in most locations if you fly high and it’s a still (not windy) day.

If you share your images, I can run some tests on bigger hardware as well.

1 Like

It’s older one… ASUS ROG G752VS:

Microsoft Windows 11 Home
Intel(R) Core™ i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM) 16.0 GB
Total Virtual Memory 45.4 GB
Available Virtual Memory 32.6 GB
NVIDIA GeForce GTX 1070 8GB

I’ll try to do something about it. Does ODM have a mobile app for iOS or what apps do you use for 3D mapping? I will try to take more pictures and hope to get a higher-quality model.
Thank you very much for your advice I appreciate it.

I’m uploading my images to google drive right now, they’ll be uploaded in about an hour… Please let me know what results you get, thanks

https://drive.google.com/drive/folders/1lvQ9EYGDuosP7rmogAyNqr-bRmxFhUFP?usp=sharing

That will be the problem with trying to go to higher quality settings, it really isn’t enough.
How is your virtual memory set up? It really needs to be set so that initial size=maximum size

See: Configuring Resources to be used with latest version of WebODM not using Docker - #2 by Gordon

1 Like

Currently running this dataset on my laptop (very slowly in virtual memory, as other computer is busy on another task), and see that WebODM thinks the images were taken at the centre of the planet -12911545.23 metres! That’s not what it says in the EXIF, so no idea how it arrived at that location :wink:

What is the ideal RAM size? I am planning to buy a new Macbook Pro so it could have better performance. I checked your reply in the thread you posted and changed the settings to maximum and started a new task with similar settings.

What the hell :smiley: how’s that possible? Does it have any effect on the quality?

As much as you can afford.

I’m not sure I understand your final questions, but ultra/ultra will give the best quality outputs.

If it’s about RAM, then I can buy as much as it needs… but I have no idea how much RAM a project like this needs.
btw, I changed those memory settings and started a new project with the same images and it has been doing this for 15 hours, is this normal? Can I see what’s happening in real time somewhere? Console or something?

I don’t think there is any need to set a high min-num-features, as I was getting hundreds of thousands of them at the default threshold. There were only 45 images in the google link you posted though. I quit the task though, as it was clear there were minimal links between tracks.
To see what is happening, click on ON for task output. It updates at random times, sometimes every few seconds, others 10 or more hours between updates.

15 hours? nothing that unusual there, especially with insufficient RAM. I’ve had tasks fail after 2 weeks!

Thank you for your willingness!
Well, I completely uninstalled ODM, installed it on my M2 SSD, and tried again with the default settings with little changes and it seems to be the best option for now.

But when I want to open “textured model” then it crashes and says:

I uploaded all 185 photos to my Google Drive, you have to scroll down.

Do you think 64GB of RAM will be enough?

The 3D model has some gaps - if I understand correctly, it’s because it has insufficient links, right? But if I take multiple pictures from the top and the side, will the program recognize where to put those images? Or what program/app should I use for 3D mapping?

I have uploaded all.zip to my Google Drive storage to folder #1 so you can check it out.

The Potree error occurs when textured model is large, but I’ve found it can still be viewed in Meshlab.

64GB RAM will certainly be enough for some jobs, such as this one with 185 images, but not for much larger ones, if you want the highest quality outputs, and in a reasonable time. Using virtual memory instead of RAM will cause tasks to take much longer to complete.

Yes, images taken from the side will be incorporated into the 3D model, just make sure there is enough overlap.

For the example I posted above here are the camera positions, the flight plan at the top was supplemented with a lot of images from the sides, flown manually to ensure good coverage of the sides and overhangs.

I zipped the photos folder, and there were only 139 photos in it when unzipped here. That left big holes in coverage, but I still managed to get a passable 3D model, albeit with a few holes.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.