Incomplete/dotted 3D model

Hello everyone, I’m Matty, a new ODM user (I bought the Windows installer). I have a small problem with my 3D model, the 3D model is made by dots only and is incomplete. I have tried different settings but the result is the same. The 2D model is okay without any issues, maybe the only problem is that the edges of the 2D model are a bit blurry because DroneDeploy takes edge shots from an angle.

Any idea what could be wrong? I’m still learning, thanks for your patience.
Matty


DJI Mavic 2 Pro
ODM for Windows

What were your settings for the task? I notice ‘Show Textures’ is not showing in the menu above "appearance’, but in the interim you could increase the points budget to 10000000 by dragging the slider across.

Do you mean these settings?: auto-boundary: true, min-num-features: 18000, use-3dmesh: true, feature-quality: ultra
Yeah, you are right, the texture model setting is not in my menu, do you think that’s the problem?
I also tried to increase the points but nothing happened :confused:

I thought perhaps you used: skip_3dmodel: False, but I’m really not sure would cause textures to be absent.

How many images and what overlap did you use (it does look like good overlap in your image showing camera locations)?

I appreciate your help, I think there shouldn’t be anything wrong, it’s probably just a small bug somewhere. The 2D model looks perfect, so there is no reason for the 3D model to look so bad.


You can check all my settings in the first post, there is a link to download all.zip. I used 185 images, it took about 4 hours to render :smiley:. I think it has enough images to create a perfect 3D model. What exactly do you mean by overlap? …I’m not sure if I did something with it

I’ve just removed your all.zip link, as Windows Defender says it contains a virus.
Overlap refers to how much each image overlaps with the surrounding images. It looks like you have plenty in that plot of camera positions.

Virus? It’s a .zip file from WebODM… I tried uploading it to another server: Easyupload.io - Upload files for free and transfer big files easily.


I created this project in the DroneDeploy app so I think it should be okay.

Windows would not download it for me, I get this:

all.zip Failed - Virus detected
https: //cdn-118.anonfiles.com/HdoeE712y2/d5ea2eb5-1659347101/all.zip

Also this:

Security Vendors’ Analysis

Seclookup Malicious

That’s weird, it normally works for me. But I just uploaded these files to Google Drive so you can check them out without downloading them.

https://drive.google.com/drive/folders/1lvQ9EYGDuosP7rmogAyNqr-bRmxFhUFP?usp=sharing

Let me know if it works.

you need to set public access for that google drive link

1 Like

That’s what Windows says:
trojan

Looking at Tracks Details in your quality report shows there is very little linkage between images over most of the area.
You could try setting pc_ultra:true and increasing the min_num_features to say 32000, to see if that helps.

Was it windy when you flew? That can make feature matching very difficult when there is a dense forest canopy.

Then it’s probably a problem with WebODM zipping the file or something. But anyway, I tried changing the min_num_features to 32000 and got an error, so should I try a smaller number?

The wind was not blowing at all, the weather was very calm and sunny. But it matched the 2D model very easily, so I don’t understand what’s going on :confused:

What was the error?
Did you try pc-quality ultra?

It says: “cannot process dataset” - I will send you a new all.zip file from this task later
I didn’t try to modify pc-quality parameter, but I put the feature-quality to ultra.

Console.txt is where the useful info about crashes is. You could just copy the last few pages of it and paste here.

Hey, I tried the default settings and it looks like we’re getting somewhere. The quality is terrible, but we are close.


And again… I uploaded it to ODM - Google Drive

Are you expecting a mesh and looking at a point cloud? For a point cloud, this is fantastic coverage over a forest canopy, so I’m wondering if perhaps this isn’t the correct product for your expectations.

If so, click on the “Textured Model” tab and activate the “Show Model” checkbox. It may take a while to load, but that will load a 3D mesh which might be more familiar.

1 Like

As can be seen in the Tracks Details image below, there is very little in the way of feature matching between flight tracks, other than around the edges, indicating that more side overlap would help.
Using ultra/ultra settings and a higher min-num-features than default may help get better matching by increasing the detected features and matches.

1 Like