Improving orthophoto results by adjusting processing parameters

Hi all,

I’m using ODM through docker in Linux Ubuntu 16.04.6, machine type: 8 vCPUs, 52 GB memory.

After a few tries I get the best orthophoto results with those
parameters -
sudo docker run --memory=“50g” -it --rm -v “/home/images:/code/images” -v “/home/output10/odm_orthophoto:/code/odm_orthophoto” -v “/home> output10/odm_georeferencing:/c
ode/odm_georeferencing” opendronemap/odm --mesh-octree-depth=11 --texturing-nadir-weight=14 --dem-resolution=0.02 --resize-to=3000 --orthophoto-resolution=0.0001 --min-num-features=50000 --depthmap-resolution=800.

I want to improve my orthophoto results in a way of:

  • Getting rid of those blurry areas in the orthophoto(example in
    orthophoto_out6.1.tiff and in orthophoto_out6.2).in the edges there were much more blurry areas.
  • Fill the white sliced areas in the edges(example in orthophoto_out6.2).

I tried to tune resize-to parameter to 4000, with no success,
also tried to increase min-num features to 60000(and also I reduce to 45000 with no success), mesh-octree-depth to 13,
matcher-neighbors to 12,tried to put --orthophoto-no-tiled, again it didn’t help, when I put --ignore-gsd the process stuck in this line-
running pdal pipeline -i /tmp/tmp2q1WgW.json > /dev/null 2>&1

Link to images and to few screen shots of the orthophoto(I have 119 images):
https://drive.google.com/drive/folders/1X26KG53tJA9JiXv11kyBUAQQa1q42PrR?usp=sharing

I will glad for some advice’s.
Thank you for the great job, ODM is fantastic!
Guy.

1 Like

What type of terrain? Urban area, crops, trees? Changing the nadir_weight to fit the terrain can have a real effect.
orthophoto-resolution=0.05 should be plenty.
I tend not to use resize

Hi spifftek70,

Thanks for the reply, the teerain is mainly consist of trees, it’s a grove of citrus trees.
I already tried --texturing-nadir-weight=14, what you suggest?
I will try to put --resize-to = -1.

Best,
Guy.

--texturing-nadir-weight <integer: 0 <= x <= 32>
                      Affects orthophotos only. Higher values result in
                      sharper corners, but can affect color distribution and
                      blurriness. Use lower values for planar areas and
                      higher values for urban areas. The default value works
                      well for most scenarios. Default: 16

How tall are the trees? I’d try 10

Will try --texturing-nadir-weight=10 and update.
The trees, are 3.2-3.7 meters tall.

that’s not very tall. If 10 doesn’t work, try 6 or 8.

1 Like

blur_exp
(example of the blurry spots)

Hi I ran with -
–resize-to=1800 --mesh-octree-depth=12 --orthophoto-resolution=0.05 --min-num-features=50000 --depthmap-resolution=800, --dem-resolution=0.02 –texturing-nadir-weight=7 --fast-orthophoto --orthophoto-no-tiled --skip-3dmodel --texturing-keep-unseen-faces.

Overall I get less blurry areas.
Is there a way to get rid of all the blurry spots?

Thanks,
Guy.

My hunch is you just don’t have data in those blurry spots. Now that we know the height of the vegetation, what was your flight height, overlap, and sidelap?

Might running without --fast-orthophoto help ? I’ve found that the orthophotos generated without fast-orthophoto seem to be slightly better in quality.

1 Like

Oh, good catch. Yes, given the height of this vegetation, the first thing to do is remove the fast ortho flag.

Thanks for the reply,

flight height: 60 meters.
overlap: 60%
sidelap:64%
About that - “My hunch is you just don’t have data in those blurry spots”, I think it’s correct in certain areas, i.e. those blurry spots change location when I change the parameters, but few areas of the orthophoto always blurry.

I will definitely try this and update!

Thanks,
Guy

Height of flight is good (the target is 4x the height of your tallest objects), but your overlap and sidelap are quite low. I recommend a minimum of 72% for both, and usually advocate for more if possible. But, we’ll see what kicking out the fast ortho flag does for you – it should help a lot.

I will pay attention to that, next flight, thanks for the advice

1 Like

Thank you so much, your advice really helped, most of the blurry spots disappeared(a few still there, I believe, it because what smathermather-cm said).
for instance,
with --fast-ortho:
before_ort

without --fast-ortho
after_ort

However, strange thing happened without --fast-ortho, the orthophoto sliced in the right edge:
slc1
but with --fast-ortho:
slc2

I will glad to know the reason for that, Thank you- spifftek70, stanley19, smathermather-cm, for your kind help and great tips.

Thanks,
Guy

1 Like

Also, you might try changing --min-num-features=50000 to --min-num-features=16000. It should work great and even speed up the process.