Importing Point Clouds

Hello guys. I downloaded point clouds from a complete task I did before in .laz format. After exporting, I clipped the point clouds in another software so I could remain with a small area I was interested in. I’ve imported the clipped point clouds back to WebODM but when I click on view 3D model, nothing is displayed. There’s also no option of texturing the point clouds. What should I do if I want to import point clouds instead of images??

1 Like

What was the other software? Did it drop attributes? Did it change the format? Did it change the LAS Specification Version that the file was written into?

I thought so but I’ve retried without importing into another software and it still doesn’t show the 3D model. The error is similar to the one reported here: Error on rendering 3D Maps · Issue #910 · OpenDroneMap/WebODM · GitHub

Platform, installation method, WebODM version, browser, etc, please.

Hello Saijin, here are the details.
Platform: Ubuntu 20.04 LTS
Installation Method: Docker
WebODM Version: v1.9.2
Browser: Chrome and Firefox
Error shown in console: GET http://localhost:8000/api/projects/1/tasks/2785ce2d-cbff-4545-97a1-10b15df0accb/assets/potree_pointcloud/cloud.js
[HTTP/1.1 404 Not Found 15ms]

1 Like

Thanks for confirming! That’s quite interesting… Why would it 404?

And to be clear, the point cloud is able to be downloaded from that project/task to disk, correct?

Yes, I’m able to download the point clouds. The problem is on visualizing it on the 3D viewer. That’s where the error gets thrown. There’s also no option for texturizing.

1 Like

Are you able to share your data? I’m curious if perhaps something is odd with it.

I have tried sharing the data using a link but still the point clouds are not displayed. The console shows the same GET request error as I reported at the beginning:
Failed to load resource: the server responded with a status of 404 (Not Found)

1 Like

Are you in a position to purge the docker installation and reinstall it?

I’m having trouble reproducing it with the latest docker image.

You mean you have installed the latest version of WebODM and it doesn’t have the issue?? If so, sure I can reinstall it if you can confirm that it works? Or the docker images have been updated to resolve the issue. I had installed WebODM last week on Thursday so it’s not an old installation. Thanks for your help.

I can’t confirm it will fix it since I can’t reproduce the behavior locally

I’m using docker under Alpine and have no issues with Gnome Web, Firefox, nor Flatpak Microsoft Edge.

Folks, to import a point cloud to WebODM it has to be in entwine format. The las/laz file is purely for download purposes, the viewer (potree) requires a quad tree format to stream the data.

Use Entwine or Untwine to convert.

1 Like

Thanks for the clarification!

QGiS 3.18+ with PDAL will also generate an appropriate EPT automatically once you select/view a LAS/LAZ.

1 Like

Just seeing this, thanks for that @dsandson. I think that’s where the problem was, I was importing zipped .las point clouds without doing any conversion.

Quick question for you Saijin, do I simply import the .las file and then export it. When exporting, which format should I export it to? I want to try this with Qgis 3.20.0 Thanks.

2 Likes

You’re going to need to make sure your QGIS was compiled against EPT/PDAL as one of the Providers. Without it, QGIS can’t interact with LAS/LAZ/EPT.
image

If you use the QGIS Browser and simply select the file in the Browser panel, QGIS will automatically create an EPT at the same filesystem level named after the file you’re previewing.

No need to actually use Open/Export or the Processing Toolbox at this point.

Aha, I’ve done that and sure I have seen the ept folder. So I should now zip it then import it into webodm I suppose?

I have zipped the ept folder and imported it into webodm but still it doesn’t fix it.

Are you inserting it into the actual data for the project?

For example, here’s where that’d be on the WebODM for Windows (native) for a particular task I’ve processed:
image

Note also the filename/foldername for the EPT that is expected. It won’t be what QGIS generates.

1 Like

Renaming the zipped ept folder as entwine_pointcloud finally did it. The point clouds are now displayed properly. Thanks all for the help.

2 Likes