Image upload - 10 minute time out, even after recent update


#1

Hi @pierotofy,

I had a similar issue to the error uploading zipped tasks which you’ve just solved. Thought it may be the same error but I’ve just updated WebODM and it is still persisting;

The error is the 10 minute time out on uploading images to WebODM. I’ve tried different data sets and it freezes at ten minutes every time, and errors out shortly after.

I’m running WebODM through Docker on Ubuntu 16.04. System is an AMD A8-7600 with 8Gb Ram, 256GB SSD. I’m accessing WebODM through Chrome on Windows 10, via an Ngrok tunnel to a subdomain. Issues obviously arising as the link isnt fast enough to upload all the images in ten minutes.

I’ve had a similar issue when running image resize in browser, although the difference is when the resizing has finished it errors out rather than commencing the image transfer to WebODM.

Error message; “XX files cannot be uploaded. As a reminder, only images (.jpg, .png) and GCP files (.txt) can be uploaded. Try again.”

Regards
David


#2

My guess it’s probably due to ngrok. I don’t think it’s meant to be used for long connections.


#3

Thanks Piero

Thats a bit disappointing. I’ve tried connecting to my external ip:8000 but think I’ve messed up Nginx settings. I’ll have a go and see if I can get a direct connection going and check if Ngrok is the issue.

David