I get the following error message when trying to load WebODM

Screenshot 2022-11-15 at 1.20.07 PM

I have Docker 4.14.0 running on a Mac Studio Ultra with Ventura 13.0.1
The Docker Desktop indicates that the engine is running.

What are the steps necessary to get WebODM to open successfully?

1 Like

Can you copy/paste the full contents of the console log? This seems strange, as the program should launch docker-compose, not docker.

1 Like

I tried the solution offered in another thread to untick the last item on the preferences menu.
That seems to have worked.

1 Like
1 Like

smathermather. That’s the solution I found and tried. it worked.

1 Like

Strange, I have Use Docker Compose V2 checked and it works.

Glad there’s a workaround available, although still unclear why this happens on some machines but not others.

1 Like

That’s why I linked to it, for the convenience of others who might find this thread later. Glad it worked.

Just FYI. Docker 4.14.1 is now out and WebODM seems to work fine with this version using Docker Compose v2.

3 Likes