How to successfully upload images for beginners

Hi all,

I am trying to upload only 8 images in the WebODM dashboard but it says ‘cannot process dataset’.

I use flylitchi for DJI drones (I have the mini 2). I had only a few images turn out with the the gimbal looking -90 degrees at the ground. I did run the images through exiftool, although I’m not really sure if that is typically necessary, I found it on YouTube and thought maybe I should try it. I’m self taught here, and it’s not proving to be easy to troubleshoot.
I use chrome on android with windows 10. I bought, downloaded and installed the WebODM software for $77 CDN.

I am attaching the 8 images I took; I know that is not very many images, I set my drone launch app to take a pic every 3 seconds, however the gimbal setting got messed up so I was left with only 8 images.
I am thinking that this was not successful because there are so few images or because it is difficult for the images to be meshed together due to the snow.

8 images

Please help!

Processing Node: node-odm-1 (auto)

Options: dsm: true, dtm: true, feature-quality: ultra, gps-accuracy: 10, use-exif: true
[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM 2.7.1 - Thu Mar 03 21:25:03 2022
[INFO] ==============
[INFO] auto_boundary: False
[INFO] boundary: {}
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: True
[INFO] copy_to: None
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 5
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: ultra
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10.0
[INFO] ignore_gsd: False
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 8
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: 15d28a7f-9221-497c-a57e-3a98a2db51e8
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 5
[INFO] pc_classify: True
[INFO] pc_csv: False
[INFO] pc_ept: True
[INFO] pc_filter: 2.5
[INFO] pc_geometric: False
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: C:\WebODM\resources\app\apps\NodeODM\data
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: [‘odm_postprocess’]
[INFO] resize_to: 2048
[INFO] sfm_algorithm: incremental
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_orthophoto: False
[INFO] skip_report: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: True
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: False
[INFO] ==============
[INFO] Running dataset stage
[INFO] Loading dataset from: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\images
[INFO] Loading images database: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\images.json
[INFO] Found 8 usable images
[INFO] Coordinates file already exist: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\odm_georeferencing\coords.txt
[INFO] Model geo file already exist: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\odm_georeferencing\odm_georeferencing_model_geo.txt
[INFO] Parsing SRS header: WGS84 UTM 20N
[INFO] Finished dataset stage
[INFO] Running split stage
[INFO] Normal dataset, will process all at once.
[INFO] Finished split stage
[INFO] Running merge stage
[INFO] Normal dataset, nothing to merge.
[INFO] Finished merge stage
[INFO] Running opensfm stage
[WARNING] C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\image_list.txt already exists, not rerunning OpenSfM setup
[WARNING] C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\exif already exists, not rerunning photo to metadata
[WARNING] Detect features already done: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\features exists
[WARNING] Match features already done: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\matches exists
[WARNING] Found a valid OpenSfM tracks file in: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\tracks.csv
[WARNING] Found a valid OpenSfM reconstruction file in: C:\WebODM\resources\app\apps\NodeODM\data\15d28a7f-9221-497c-a57e-3a98a2db51e8\opensfm\reconstruction.json
[ERROR] The program could not process this dataset using the current settings. Check that the images have enough overlap, that there are enough recognizable features and that the images are in focus. You could also try to increase the --min-num-features parameter.The program will now exit.

I’m 100% open to watching how to do all of this on YouTube, I have been trying to find the help for a couple of days and I thank you in advance for any help you can give me.


8 images is very probably not enough, you need a decent amount of both sidelap and overlap for the feature matching to work. See Tutorials — OpenDroneMap 2.8.0 documentation for guidelines on the capture pattern.

Don’t worry about the gimbal being at -90, the Mini 2 moves from that angle as soon as you start flying and off nadir angles are probably better as described in the link above. I normally aim for -75 to -85 degrees and find this gives better 3d models.

You also don’t need to use exiftool, the images will work straight off the drone.

All of the orthophotos at this link were produced with a Mini 2 and ODM. To date I’ve flown all my missions manually with DJI Fly, I’ve just got DroneLink (equivalent to Litchi) and will try that to fly automated mapping missions.




Don’t feel discouraged! The first collects are usually a bit of a trial for everyone :slight_smile:

ralley has you squared away!

Try another collect with their guidance and let us know how it goes!


Awesome, thanks so much!! I really appreciate your help and I’m looking forward to our Nova Scotia snow to melt away so I can get more images and keep practicing!

Kind regards!!


Looking at your 8 images, I figured it wasn’t an ideal distribution, but something should be obtainable, as there was plenty of detail in the trees and building.

Here is the orthophoto

This is the 3D, looking straight down, showing camera positions.

3D again, with plenty of holes, but another 20 or 30 images could have made for a nice result.

[Taggart Road - 03/03/2022](javascript:void(0):wink:

8 images 00:03:42

|Options:|dem-resolution: 1, dsm: true, dtm: true, feature-quality: ultra, min-num-features: 12000, orthophoto-resolution: 1, pc-quality: ultra, pc-rectify: true, use-3dmesh: true|
|Average GSD:|1.45 cm|
|Area:|115.43 m²|
|Reconstructed Points:|484,732|


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.