How could i fix this?

#1

I’ve run a side by side comparison with WebODM and another program to produce a single 3D model, but came across one issue that ruined the final model that WebODM produced and I’m wondering what options could be changed to improve or prevent this from happening (pics below).

It’s quite a funny data set so I’ve attached some pictures as it’s hard to explain! :smiley:

Other program output with no issues -
Chimes

WebODM -

The model was inside an orb/egg (most likely due to the way the pictures were taken, I’m not really concerned about this, but i thought i’d share as it’s funny -
Orb

So inside the egg, you can see the model surrounded by the rest of the blury images that were not part of the main focus -
InsideOrb

Another less chaotic view with no textures -
InsideOrb2

What I had left when i removed all the excess mesh -
NoChimes

The model itself is great, the texture detail is very good and I’m really happy with it, but it’s the big bulging part at the front and the missing wind chimes that have me confused. What options can I change to improve this part? The dataset was run as “3D Model” and was set to not resize images. Nothing else was changed.

Thanks!

Great work on WebODM too guys, It’s really coming along nicely showing some great improvements, features and stability!

#2

Mm, the first thing I would try is to set --pc-filter to 0. It’s likely that the wind chimes are getting cut away. You could also try to lower the --mve-confidence threshold to 0.25.

That’s a cool dataset!

1 Like
#3

Maybe the “process unseen faces” is enabled? I had this problem once on a process of river flowing through a valley …

1 Like
#4

Thanks - Just tried those 2 options and it gives this error :frowning:

Process exited with code 1" means that part of the processing failed. Try tweaking the [Task Options](javascript:void(0):wink: as follows:

  • Increase the min-num-features option, especially if your images have lots of vegetation
#5

Strange, just noticed this error message appears nearly instantly after I restart from ‘Meshing’. I don’t think it’s anything to do with number of features :man_shrugging: