Holes in Orthomosaic

good afternoon

I captured a survey dataset at the weekend using DJI pilot, flying single grid at 70m using an M210RTK v2, flying with RTK enabled and an X4S sensor. I’ve processed the set using both DroneDeploy and WebODM (I’m very new to ODM but have been using DD for a few years now). When processing the data using the Fast Orthophoto pre-set but the results have a number of large holes that don’t appear in the DD map.

Whilst I appreciate it’s a fairly uniform field so matches are difficult and I’ve tried numerous different settings, including high resolution, I can’t seem to get rid of the hole. Any suggestions for parameters I can play with please

A screenshot of the ODM version can be seen here: https://dsaerial.co.uk/wp-content/uploads/2021/08/Field-ODM.png

and the DD version can be seen here for comparison: https://dsaerial.co.uk/wp-content/uploads/2021/08/Field-DD.png

Many thanks

Lee

1 Like

Welcome!

Sorry you’re having a spot of trouble.

Are you able to share the data somewhere like dronedb.app? I would like to have a go at it.

Hi Saijin

I’m just uploading the dataset to dronedb now - around 6.5gb. I’ll update when it’s complete

Thanks

Lee

1 Like

I’ve uploaded to here temporarily
https://testhub.dronedb.app/r/dsaerial/e6k4w48mjtgshdb8

Thanks
Lee

1 Like

Thanks! Nabbed it.

Give me a bit to work it over and see what I can do :slight_smile:

1 Like

Were you moving when you took these shots? I’m seeing a bit more motion blur than I’d like.

1/60s Shutter doesn’t give you much leeway for movement.

Thanks once again, yes the shutter was slower than it would usually have been so there is more motion blur than ideal.

I’ve re-processed again overnight using MetaShape and the ortho has come out fine - I re-processed on ODM using the following settings and the holes were even bigger, so I must be missing something fairly basic!

Options: dem-resolution: 2.0, dtm: true, mesh-octree-depth: 14, min-num-features: 10000, orthophoto-resolution: 2.0, pc-quality: high, resize-to: 2048, rerun-from: dataset

1 Like

Don’t use the resize-to here, it can make it much harder to find features for matching

I’m pre-processing the images now so hopefully can get results soon.

1 Like

No Pre-Processing:

Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, gps-accuracy: 3, mesh-size: 300000, min-num-features: 16000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

image


Pre-Processing:

Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, feature-type: hahog, gps-accuracy: 1, mesh-size: 300000, min-num-features: 16000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

image

I’m still struggling with gaps in the reconstruction, and I’m pushing things pretty high.

I’m going to see if I can do anything else.

That’s awesome, thank you - it seems the images are the main cause of the problem - I’ll try and re-fly this weekend and retrieve a better dataset. Hopefully that cures the problem

1 Like

Is it possible with your sUAS/Flight Plan to “stop” for image collections? I know it’s a massive pain and adds many minutes on a job this size, but it may help if you can’t keep the shutter speed down to something faster than 1/60s.

Once you do re-collect, let us know how things go, and feel free to reach out to me again if you want me to take a go at processing it with you.

1 Like

Hey @Ossie, could you please share this dataset?

It shows an Error: Unauthorized…

image

I’m just experimenting with preprocessing.

Thanks

1 Like

Hi, yes, I’ve removed the dataset - it really was operator error in this instance, I’m re-shooting this week

Thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.