Hi everyone ! A first attempt

I just want to share my first experience with WebODM.

I’ve a spark and wanted to map a piece of land …
I’ve found OpenDroneMap on the net and thought it could help.

First I did not succeed in executing the flight plan (aero ranger) for geofence issue (there is no restricted area nearby …). So I did fly manually to cover the area (2 datasets 50m and 70m).
Back to home, WebODM digested the data but the results were partial (missing parts) and when I tried GCP the altitudes were wrong. :sweat:
Then I bought the Piero’s guide and found explanation about the different parameters. Great pieces of information ! However I’m a bit confused about what I had to do to get the full coverage: min-num-features: 1000 (instead of 8000) & matcher-neighbors: 0 (instead of 8). Reading the log it seemed to me that both were eliminating too much images at default value.
I’m already happy with what I get:

image

image

(I wanted to attach the log file but txt files are not allowed)

Of course there is plenty of room for improvement and your comments are welcome.
One point I would like to solve is the usage of gcp to make the map fit better on google map (if that makes sense) without losing the tilt.

Thanks for this great piece of software !

3 Likes

Looks good! What processing node did you use to generate your Model?

I’ve installed docker and webodm on debian buster, i5 + nvidia (but I’ve read that webodm does not use the gpu).
So the used node is: node-odm-1.

Okay, I’m using Windows 10 Pro with Docker and GIT, Ryzen 9 9300 with 32Gb memory. I just wish I could get to the bottom of why when I process images with the Node MicMac the 3D viewer doesn’t display it. It works fine when I Use Node ODM-1 but as soon as I process through node MicMac, boom no 3D model displays…

Other than that this software is amazing, i have been really impressed with it!

Oh yes the reason I asked about which Node you used was because MicMac apparently gives better results for your 3D models. I have been using drone deploy for my automated flights, if you haven’t tried it I would highly recommend.

Which kind of benefit does bring MicMac ? Better mesh ? Better texture ? Faster ?

Same for me. Here is the beginning of a long list of errors (always the same).

NodeMICMAC by DroneMapper.com
[DEBUG]   Trying `CDLL(libc.so.6)`
[DEBUG]   Library path: 'libc.so.6'
[DEBUG]   DLL: <CDLL 'libc.so.6', handle 7f90fdf8a000 at 7f90fdf017d0>
[INFO]    Initializing NodeMICMAC app - Fri Aug 14 14:23:37  2020
[INFO]    Namespace(camera_cloud=False, ccd_height=None, ccd_width=None, gcp=None, image_footprint=False, images=None, matcher_distance=None, max_concurrency=4, multi_scale=False, name='3da2e698-61d4-49f2-9e34-58445e9fd4ca', project_path='/var/www/data', remove_ortho_tiles=False, resize_to=800, zoom=4)
[INFO]    Starting..
[DEBUG]   running exiftool -filename -gpslongitude -gpslatitude -gpsaltitude -T -n *.JPG > imageEXIF.txt
[INFO]    UTM - 23
[INFO]    Hemisphere - south
[INFO]    JPG
[INFO]    {'utm_zone': 23, 'hemisphere': 'south'}
[DEBUG]   running mm3d XifGps2Txt .*.JPG
".*.JPG": 157 matches.
Error: Directory Iop: Next pointer is out of bounds; ignored.
Error: Directory (Last IFD item) with 19712 entries considered invalid; not read.
Error: Directory (Last IFD item): Next pointer is out of bounds; ignored.
Error: Directory Iop: Next pointer is out of bounds; ignored.
Error:
Directory (Last IFD item) with 19712 entries considered invalid; not read.

The orthophoto looks indeed more natural, more detailed with micmac than odm-1 (with the parameters I’ve used at least):

micmac
image

odm-1
image

1 Like

Mesh and texture as far as I know.