Help (with a lot of TLC) required!

I have used various mapping/photogrammetry apps, including Metashape and online systems such as MapsMadeEasy, but decided to give WebODM a try as I really like the output - and need to keep costs down. However, I am virtually computer illiterate so, to make life easy, paid for the Windows installer.

Everything starts off ok but, when processing, it stalls with an “error 132” message. Reading forums/github it would appear that I am one of those folk whose processor SHOULD work but, for some reason, is not recognised.(Github #378)

So I’m now in a situation where, having paid for an “easy” installation, I have to attempt things that I really do not understand. I have absolutely no idea where to begin, as I have never complied anything in my life and the syntax of computer language is alien to me. Even looking at the tutorials bring me out in a cold sweat, as they do seem to presume a degree of knowledge which I do not have!

Is there anybody out there, with the patience of a saint, who would be willing to talk me through the process of getting WebODM up and running, please?

1 Like

Welcome! Hopefully we can get you sorted!

First, please provide full specs for your computer. If it is an un-modified commercial computer, the model/part number and make should do.

Second, please let us know what version of Windows you’re using.

Third, if possible, provide your data somewhere we can get to it.

Thanks!

Thank you!

I am operating Windows 10 (64)

Operating System: Windows 10 Home 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: p6-2175ea
BIOS: Ver: HOL_718.ROM vHOL7.18 (type: BIOS)
Processor: AMD A8-3820 APU with Radeon™ HD Graphics (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 7666MB RAM
Page File: 8498MB used, 2239MB available

1 Like

Sorry, you also asked for data. What data would you need?

Good info, thanks. 8 GB RAM is going to constrain you, in spite of the what the docs say.
How much hard drive space do you have available?

re: “data” - if you can post your photoset, some of us can try to process it too, and see if it’s something about the drone photos vs. your software config.

Along those lines… are you able to process the “brighton beach” or “toledo” datasets from here? https://github.com/OpenDroneMap/ODMdata

1 Like

The photos I used processed fine on Lightning, MapsMadeEasy and Agisoft, so I don’t think they are the issue. I reckon 8GB may be pushing it a bit but, if its slow, I don’t mind too much as Agisoft can take several hours too. Looking at other threads, there does seem to be some sort of issue surrounding my processor - I just do not understand the workaround. I’ll see if I can find the link from this forum…

This from Github - https://github.com/OpenDroneMap/WebODM/issues/330

and (similar?) from this forum New Install Error 132 codes and virtualenv has stopped

(The problem is, I thought this would be a fairly easy install, as my knowledge of computers/scripting/programming is next to nil!)

Just realised - I don’t even know how to download the sample images from GitHub. This might be a painful process for you guys…

Hit the Download as… Button on the github page, when you’re at the root of the repository and on the Code tab.

1 Like

Also, given your current situation and level of comfort, I think WebODM Lightning is a perfect fit for you!

Hosted processing, very easy to use, and pretty powerful servers doing the work.

It is paid, but the fees are very fair. You might have enough demo credits to process your data, if it’s small enough.

Cost go directly to ODM development, much like the installer purchase.

I have an account for work at the town I do, and I have a local install for personal fiddling around.

Sometimes, you just need to hit upload and get data back without thinking more about it :man_shrugging:

1 Like

Thank you! I know what you mean, but the whole point of my trying WebODM was to have a no-cost system as I operate on a fairly tight budget…

So having successfully downloaded and unzipped the Brighton images, I still gat the error 132 with /code/run.sh: line 5: 8338 Illegal instruction python3 $RUNPATH/run.py “$@”

I wondered whether this might be the solution, but not sure how to implement it?

Hi @pierotofy, we’re working with @julianpalladino on this issue.
The problem wasn’t in ODM, node-ODM nor WebODM so rebuilding these projects led us to the same error. After long hours of debugging we found that the problem was/is in a related project MVE (used by mvs-texturing): https://github.com/nmoehrle/mve

In particular, in the file:


They added the flag -sse4 which is not supported by old AMD processors (ours is an AMD Phenom II X6 1090T). So, we removed that flag and now everything is working :slight_smile:

I think that the best thing to do is to transform MVE in a CMakeList based project, so for now a good fix would be to change:


and point to forked projects that can be controlled by the ODM team, and also try to avoid cloning external libraries from master branches to gain stability in the building process.

Thanks!
Francisco

Originally posted by @fragofer in https://github.com/OpenDroneMap/WebODM/issues/330#issuecomment-411550656

It looks like you need to recompile the project to get it to run on your unsupported CPU/processor. It looks that that generation A8 APU has very limited SSE4 instruction support.

At this juncture, I’d suggest at least making a starter WebODM Lightning account and checking if you can process your dataset with the demo credits. It might be the best workflow for you at the moment.

1 Like

I have already tried Lightning, and processed the runs with excellent results. I have also purchased credits to tide me over. However, because I sometimes map large areas (for archeology, cropmarks etc), I was really wanting to generate locally, rather than in the cloud, in order to keep costs down. This “low-cost” option has already cost me a fair amount of money in terms of the Windows installer and extra Lightning credits.

If UAV4Geo is unable to get you running on your hardware, they’d certainly honor their return period/warranty, so I wouldn’t think of your Installer license as sunk costs quite yet.

1 Like

That’s good to hear, but really I want to get it up and running. If I can, I don’t mind the financial hit. It is a brilliant piece of kit!

1 Like

Hey Andy, a couple of quick thoughts… the re-compiling path is a pretty technical process and difficult to troubleshoot from the forums. It’s a challenge even for technical users. I would also caution against investing too much time in a special install on a machine with only 8 GB of memory. If the goal here is to process large datasets, it’s likely that you would get it working on your processor only to find out that your jobs run out of memory. I’m thinking that getting it working on this machine may be a bridge too far. I understand you’re on a limited budget, but your time and $$ might be better spend on procuring a refurbished office workstation for local processing. Depending on your location, you can often find a very capable machine with a common processor and 32 GB RAM for ~US$ 400 or so.

1 Like

Corey is right. I use an Odroid H2 plus. With 32GB RAM and a 1TB drive, it’s a capable little machine for sub $400, although $400 is a fair amount of processing on webodm.net.

No matter what path you take, larger datasets are not going to be 0 cost, even going free and open source.

3 Likes

Cheers, Guys. Thanks for all your ideas. Obviously, I don’t expect to get something for nothing, but I was keen on the idea of processing locally, with the flexibility that affords me to do more than one run, or vary different parameters within the run. That said, Lightning is VERY good and I am very pleased with the output - particularly with the various crop health indices which are very useful for pulling out faint archaeological crop marks.

4 Likes