Help minimize ghosting or blurring of a roof in ortho

What can I do to minimize this ghosting or blurring of a ortho on a roof? Most of the photos in the project were oblique with a few nadir. Any ideas or help would be appreciated.
WebODM 1.7.1
API Version 2.1.3
Engine Version 2.4.2
Here is the options I have run the project with.

camera-lens: brown, crop: 0, debug: true, dem-resolution: 2, dsm: true, dtm: true, feature-quality: ultra, gps-accuracy: 3, mesh-octree-depth: 12, mesh-size: 1000000, min-num-features: 24000, optimize-disk-space: true, orthophoto-resolution: 2, pc-quality: ultra, verbose: true

ghosting

1 Like

Iā€™m not very familiar with how to address these issues.

The section in the OpenDroneMap: The Missing Guide book about texturing flags seems like it may help.

Have you explored any of the --texturing- variables yet?

1 Like

Do you get better results if you turn on --use-3dmesh?

2 Likes

I tried to add texturing-skip-local-seam-leveling and still had the issue. I then rerun with texturing-skip-local-seam-leveling and use-3dmesh and that seemed to do the trick.
ghosting2

2 Likes

Looking CLEAN!

Lovely.

2 Likes