Gdalbuildvrt failed due to insufficient disk space on Lightning

Finally got gdal to Out-Of-Space on Lightning! This is a surprise.

Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, feature-type: hahog, matcher-neighbors: 0, mesh-size: 300000, min-num-features: 64000, orthophoto-resolution: 1, pc-ept: true, pc-filter: 0, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

Cell Tower Survey:

[INFO]    running gdalbuildvrt -input_file_list "/var/www/data/392f6e1a-f11e-4043-83ab-6e3773d52666/odm_dem/tiles_list.txt" "/var/www/data/392f6e1a-f11e-4043-83ab-6e3773d52666/odm_dem/tiles.vrt"
0...10...20...30...40...50...60...70...80...90...100 - done.
[INFO]    running gdal_translate -co NUM_THREADS=8 -co BIGTIFF=IF_SAFER --config GDAL_CACHEMAX 46.55% "/var/www/data/392f6e1a-f11e-4043-83ab-6e3773d52666/odm_dem/tiles.vrt" "/var/www/data/392f6e1a-f11e-4043-83ab-6e3773d52666/odm_dem/tiles.tmp.tif"
ERROR 3: /var/www/data/392f6e1a-f11e-4043-83ab-6e3773d52666/odm_dem/tiles.tmp.tif: Free disk space available is 21652918272 bytes, whereas 42121714104 are at least necessary. You can disable this check by defining the CHECK_DISK_FREE_SPACE configuration option to FALSE.
Input file size is 99669, 105654

===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
Traceback (most recent call last):
File "/code/stages/", line 94, in execute
File "/code/opendm/", line 340, in run
File "/code/opendm/", line 340, in run
File "/code/opendm/", line 340, in run
[Previous line repeated 6 more times]
File "/code/opendm/", line 321, in run
self.process(self.args, outputs)
File "/code/stages/", line 97, in process
File "/code/opendm/dem/", line 221, in create_dem
run('gdal_translate '
File "/code/opendm/", line 106, in run
raise SubprocessException("Child returned {}".format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1

===== Done, human-readable information to follow... =====

[ERROR]   Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See

Well this explains it lol

I’m guessing the background is generating a very large orthophoto since points are reconstructed from so far away.

We really need a way to allow extents and backgrounds to be filtered.

1 Like

This slipped past the pc-geometric, or does it not really impact that?

I’m surprised it failed given basically the same input parameters, though HAHOG instead of SIFT.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.