Fresh install does not start on MAC

Hi,

Trying to manually install this on a MAC, Mojave 10.14.5. I got docker running, git’s installed but I get a number of errors when I enter “./webodm.sh start” in Terminal.
I have copied the results after that entry below, bunch of “FAILED” near end

Thanks for any help

Last login: Mon Sep 2 19:32:04 on ttys001

Cengizs-MacBook-Pro:~ goo$ cd WebODM

Cengizs-MacBook-Pro:WebODM goo$ ./webodm.sh start

Checking for docker… OK

Checking for git… OK

Checking for docker-compose… OK

Starting WebODM…

Using the following environment:

================================

Host: localhost

Port: 8000

Media directory: appmedia

SSL: NO

SSL key:

SSL certificate:

SSL insecure port redirect: 80

Celery Broker: redis://broker

Default Nodes: 1

================================

Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1

Starting node-odm … failed

Starting broker … failed

Starting db … failed

Starting worker … failed

Starting webapp … failed

ERROR: No containers to start

Creating network “webodm_default” with the default driver

ERROR: readlink /var/lib/docker/overlay2/l: invalid argument

Hi @cengiztanc :hand: see Installation Error: No containers to start

The tty file was indeed in another location, and I somehow made it work.
Thank you!!!

1 Like