First mapping mission. Exception: Child returned 137

Dear WebODM user,

this is my first time using WebODM. This morning, I flew my DJI Mavic mini 1 on a sample mapping mission using DroneLink.

Screenshot 2021-02-21 at 13.34.30

I flew in a grid pattern resulting in 159 images. However, when running the default mapping task in WebODM in my browser, the task fails with exit code 137. A search indicates this might be due to a RAM limitation. My Docker is set to default at 2GB of RAM. What would you guys recommend, is running these tasks locally recommended at all? I’ve now set Docker to 8GB and will run again. How do I know how much RAM is required for a task? (Ballpark estimate)

Link to your images:
Y2021M02D21_Drone_map_test_v01 - Google Drive

Entire task output (not just parts of it) for everyone to read:

  1. Did you fine tune any parameters? Which ones?

I tried a few options including “Default”, “High Resolution” and Fast Ortho

  1. If applicable, what browser are you using? What operating system? How did you install the software? Be precise.
    MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports)
    16 GB 3733 MHz LPDDR4X
    2 GHz Quad-Core Intel Core i5
    Intel Iris Plus Graphics 1536 MB
1 Like

Welcome! Always as much RAM as is tenable. Nothing bad ever comes from having too much :sunglasses:

Let us know how you get on with 8Gb! May nor be enough yet, though.

Also, great first issue post! We have everything we need to help you!

2 Likes

Thanks Saijin for your answer. I figured that docker stats in your terminal returns the current CPU / memory stats. Screenshot 2021-02-21 at 14.18.18

Changing the Memory to 8GB has solved the issue.

For future users, go to Docker → preferences → increase RAM → restart

4 Likes

If you’re not multitasking when processing, you might be better served by bumping docker to 12GB. OSX should be fine sitting there with 4GB.

If it is too constrained of a system for local processing, WebODM Lightning (by UAV4Geo) works incredibly well and has very fair pricing. All money goes back into development of OpenDroneMap for everyone :blush:

3 Likes