Failure to process anything

Hello all!

I have just installed WebODM on 2 computers (both Windows 11), the only difference i could see in the process is that computer 1 requested installation of C++ redistributable during install (which i did). Before generating any of my own images (and because the weather is awful atm!) i decided to try and process some sample datasets, starting with the banana (as it had fewest images). Using the base settings for 3D model (nothing changed in options)

Computer 1: Consistently fails to process anything
Computer 2: works just fine

I tried a couple of the other datasets and same story, Computer 1 fails every time, computer 2 works fine. Both Intel I5 with 8g RAM, computer 1 now updated to 32g RAM (had ordered these anyway, just hadn’t arrived before 1st try) which didn’t make a difference.

Any ideas? i feel like it may be related to the C++ redistributable… this line seems to relate to C++ when i google it but thats the limit of my technical knowledge! “[WARNING] Child returned 3221225781”

Log file for failed run below (for banana on computer 1), apologies for the length!

[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\opensfm\bin\opensfm” export_visualsfm --points “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm”
[INFO] Finished opensfm stage
[INFO] Running openmvs stage
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\opensfm\bin\opensfm” export_openmvs “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm”
[INFO] Running dense reconstruction. This might take a while.
[INFO] Estimating depthmaps
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\DensifyPointCloud” “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\scene.mvs” --resolution-level 2 --min-resolution 512 --max-resolution 2048 --max-threads 12 --number-views-fuse 2 -w “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\depthmaps” -v 0 --cuda-device -1
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\DensifyPointCloud” --filter-point-cloud -1 -i “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\scene_dense.mvs” -v 0 --cuda-device -1
[INFO] Finished openmvs stage
[INFO] Running odm_filterpoints stage
[INFO] Filtering D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\scene_dense_dense_filtered.ply (statistical, meanK 16, standard deviation 2.5)
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\FPCFilter” --input “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\scene_dense_dense_filtered.ply” --output “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply” --concurrency 12 --meank 16 --std 2.5
*** FPCFilter - v0.1 ***

?> Parameters:
input = D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\opensfm\undistorted\openmvs\scene_dense_dense_filtered.ply
output = D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply
std = 2.5
meanK = 16
boundary = auto
concurrency = 12
verbose = no

→ Setting num_threads to 12

?> Skipping crop

?> Skipping sampling

→ Statistical filtering

?> Done in 0.5799s

→ Writing output

?> Done in 0.2619s

?> Pipeline done in 0.8418s

[INFO] Finished odm_filterpoints stage
[INFO] Running odm_meshing stage
[INFO] Writing ODM Mesh file in: D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.ply
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply” --out “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.dirty.ply” --depth 12 --pointWeight 4.0 --samplesPerNode 1.0 --threads 11 --bType 2 --linearFit
[WARNING] Child returned 3221225781
[WARNING] PoissonRecon failed with 5 threads, let’s retry with 2…
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply” --out “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.dirty.ply” --depth 12 --pointWeight 4.0 --samplesPerNode 1.0 --threads 5 --bType 2 --linearFit
[WARNING] Child returned 3221225781
[WARNING] PoissonRecon failed with 2 threads, let’s retry with 1…
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply” --out “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.dirty.ply” --depth 12 --pointWeight 4.0 --samplesPerNode 1.0 --threads 2 --bType 2 --linearFit
[WARNING] Child returned 3221225781
[WARNING] PoissonRecon failed with 1 threads, let’s retry with 0…
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon” --in “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_filterpoints\point_cloud.ply” --out “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.dirty.ply” --depth 12 --pointWeight 4.0 --samplesPerNode 1.0 --threads 1 --bType 2 --linearFit
[WARNING] Child returned 3221225781
[INFO] running “D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\ReconstructMesh” -i “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.dirty.ply” -o “D:\WebODM\resources\app\apps\NodeODM\data\d9a7324c-b0cf-4220-b8f7-c4dd25f023cb\odm_meshing\odm_mesh.ply” --remove-spikes 0 --remove-spurious 20 --smooth 0 --target-face-num 600000 -v 0
===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
Traceback (most recent call last):
File “D:\WebODM\resources\app\apps\ODM\stages\odm_app.py”, line 94, in execute
self.first_stage.run()
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
[Previous line repeated 3 more times]
File “D:\WebODM\resources\app\apps\ODM\opendm\types.py”, line 327, in run
self.process(self.args, outputs)
File “D:\WebODM\resources\app\apps\ODM\stages\odm_meshing.py”, line 24, in process
mesh.screened_poisson_reconstruction(tree.filtered_point_cloud,
File “D:\WebODM\resources\app\apps\ODM\opendm\mesh.py”, line 205, in screened_poisson_reconstruction
system.run(’"{reconstructmesh}" -i “{infile}” ’
File “D:\WebODM\resources\app\apps\ODM\opendm\system.py”, line 106, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1

===== Done, human-readable information to follow… =====

[ERROR] Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See Flying Tips — OpenDroneMap 2.7.0 documentation

1 Like

Welcome!

Sorry for the trouble.

You can always manually install the latest VC++ Redsists here:

You can safely install the x86/x64 versions (skip ARM64) for the 2015-2022 VC++ redists, and honestly I like installing the latest patches for all the prior versions as well to ensure that any apps that rely upon the VC++ redists on my machine will be using the latest/supported versions.

Thanks for the help Sajin_Naib!

OK, so far i have tried:

  • install the C++ redistributable propmpted by webodm on install (1st post)
  • install C++ redistributables manually (webodm requests 2013 but i tried the more recent version also)
  • as above but uninstalling all C++ redistributables 1st in case they were messed up somehow
  • both of the above including uninstall and reinstall webodm afterwards

I’m still coming up with the same errors. Is there anything else in the log / debug that looks like it might be the cause do you think?

Rhys

OK Fixed

Went into file referenced in the first error message
"D:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\PoissonRecon”
and tried to run PoissonReon on its own, which then gave the error message with the dll I was missing (can’t remember which).

After a quick google it turns out I needed both the x86 and x64 version of C++ redistributable and I’d only been installing the x64 versions (I realise now you suggested installing both, I assumed when I read first to install the version for my system - x64!)

So in short, thanks for your help and sorry for wasting your time not following your advice properly! May be worth the automatic download/prompt on install to include both x86 and x64, I’m not sure whether that’s within your control though!

again thanks for your help

Rhys

1 Like

No worries!

Hmm… I think we can grab both architecture versions with the installer framework we use, but to be frank, that’s outside of my knowledge/experience. I’ll upstream that to Piero, though.

Thanks for confirming, and good processing!