Exception at MVS


#1

I love WebODM! Have been using for a while and it is a great piece of software. The only problem I ever had was when I ran out of memory mapping a 75 acre subdivision with 395 pic’s. So I bought a new computer with more memory (32 Gb RAM) and loaded up Linux Mint 19 as the OS. I installed WebODM yesterday with no problems during the install and when the webpage came up I noticed some new features. Nice! Simple list is cool.

Do you feel the big hairy BUT coming?

None of the projects I have run have completed. Even projects that were run on the previous computer. All fail during MVS with:

File “/code/scripts/smvs.py”, line 70, in process
system.run(’%s %s %s’ % (context.makescene_path, tree.mve_path, tree.smvs))
File “/code/opendm/system.py”, line 34, in run
raise Exception(“Child returned {}”.format(retcode))
Exception: Child returned 1

A complete copy of task output for a 75 pic project that failed with “Process exited with code 1” is available at https://pastebin.com/zsY1rjkG This same project ran successfully on the older version of WebODM.

There are 3 projects that have this same problem. All exited with the same code.

This is a new laptop. All the software on it has been installed over the last 2 days. Latest available stable versions of Docker, Python, PIP and git. the only change to Docker was to store containers on the Data drive instead of the primary SSD. All the auxiliary software seems to be working fine.

Thank you for your time.


#2

Glad to hear WebODM is working out for you :slight_smile:

The problem could be linked to the images themselves:

2018-12-22 12:20:56,337 DEBUG: Undistorting image YUN02904.jpg
Corrupt JPEG data: 168 extraneous bytes before marker 0xdb
2018-12-22 12:20:56,449 DEBUG: Undistorting image YUN02904.jpg

Would you be able to share the images and tell us if you are using the “Resize” feature of WebODM when uploading the dataset (or are you skipping the image resize)?


#3

I have not resized the images as I had trouble with that when I used a previous version of WebODM. All of the images have 168 extraneous bytes before marker 0xdb. This never bothered the program when I used it in the past. This is a quirk of the camera. How many images do you want? Will one do? The folder with 71 images is 580Mb.

YUN02904

Thanks for your help. I really like your software.


#4

Were previous versions working even with SMVS? Does it work if you run the program with the --use-opensfm-dense flag?


#5

This is a project that ran successfully with a previous version. I just ran it again with the --use-opensfm-dense flag set and it failed again with the same error. Please see log file at https://pastebin.com/C5EfiFUt

I do not know how to identify versions of the software. the version I am using now was installed using the command below on Dec 21, 2018.

git clone https://github.com/OpenDroneMap/WebODM --config core.autocrlf=input --depth 1

The previous version was loaded with the command available from github on Nov 18, 2018.

I would love to read the documentation for this software. Is there a link you can provide so I can RTFM?


#6

Something is not right… the output you just copy/pasted seem to have been processed without the --use-opensfm-dense flag. Try to remove the task and start over?

We have some documentation at https://opendronemap.org/docs/


#7

I removed the task and started fresh. Same results. Here is the pastebin.

https://pastebin.com/Jiz5i2Hr

Thanks for the link.


#8

Just to make sure, you are seeing this line next to your task correct?

image

Also, are you running the latest version of WebODM? When did you last run ./webodm.sh update?


#9

No. I am running WebODM from localhost. To set the flag I check use-opensfm-dense box in the Options list in Edit options. Let me update and I will get back to you with the results of the next run.


#10

SUCCESS!!!

My fault. I was clicking the checkbox above the flag instead of below.

Thank you for all your help.