Error with --camera-lens brown parameter

Hi,
I am trying to force ‘brown’ on a data set taken with Sony A7 which defaults to ‘perspective’. Feeding this parameter to the command line yields:

run.py: error: unrecognized arguments: --camera-lens

Documentation specifies this as a valid option.

Any ideas why this param was not accepted?
Tnx

1 Like

I had this same issue as well. I think this was just recently rolled into master and I’m not sure which commit, but if you can update ODM and all its components, you should be able to use it.

1 Like

Tnx @Saijin_Naib,
I am just using the standard docker command
docker run -ti --rm -v /my/project:/datasets/code opendronemap/odm --project-path /datasets

How do I know which version am I using?

1 Like

Update your docker image…

Just tried

docker pull opendronemap/opendronemap

from here: https://hub.docker.com/r/opendronemap/opendronemap

and the result was:

user@user-dell5400:~$ docker pull opendronemap/opendronemap
Using default tag: latest
Error response from daemon: manifest for opendronemap/opendronemap:latest not found: manifest unknown: manifest unknown

Is this the wrong way to update?

1 Like

Try docker pull opendronemap/odm.

1 Like

worked. Kudos.

1 Like