Error starting webodm.sh start --gpu "Unsupported config option for services.node-odm: 'deploy'"

Error when run with --gpu option

1 Like

docker-compose.nodeodm.gpu.nvidia.yml:

1 Like

nvidia-smi:

1 Like

Welcome!

Sorry for the trouble.

How did you install/deploy WebODM? By following the instructions on the GitHub?

Yes, everything is according to the instructions from GitHub.

I also used this guide:

1 Like

What OS are you running on? Please explain your system and setup.

It is this error that occurs on ubuntu server when run with --gpu parameter.
There was no such error on Ubuntu desktop.

I also tried to run it on Windows 11 on WSL2, the graphics card is detected, but all calculations take place exclusively on the CPU.

Launched on:
RTX 3070 and Quadro P500 graphics card.

1 Like