Error processing TIFFs with EXIF tags

Hi -

I’m running WebODM via Docker on a 64-bit Windows 7 laptop (8 Gb RAM) and am having problems processing a set of TIFFs with EXIF tags. The EXIF tags were added using EXIFTOOL and I can confirm they via Properties > Details or from exittoolinfo. For the task I have enabled use-exif and am not using a GCP file but am consistently getting the message:

“An orthophoto could not be generated. To generate one, make sure GPS information is embedded in the EXIF tags of your images, or use a Ground Control Points (GCP) file.”

I tried converting the TIFFs to JPGs and have successfully processed them, though the georeferencing is off and the elevations on my DEM are negative (despite the GPS Altitude set to above sea level). Below is the output from the processing console and images are available here

Note: I’ve just realized that the GPSLongitude is incorrectly set to W instead of E (I’m in New Zealand). I’m assuming this shouldn’t be fatal for processing - though the images would end up somewhere east of the Chatham Islands. (The JPGs had the correct tag and ended up within 5 or so metres of where they should be.)

Some of the ODM sample datasets used TIFFs so I’m assuming they are supported in WebODM.

Any suggestions are MOST welcome.

Thanks -


[INFO] Initializing OpenDroneMap app - Thu Dec 07 01:07:15 2017
[INFO] Running ODM Load Dataset Cell
[DEBUG] Loading dataset from: /var/www/data/e492c60b-7886-432e-b3e6-396e8db18795/images
[DEBUG] /var/www/data/e492c60b-7886-432e-b3e6-396e8db18795/images
[ERROR] Not enough supported images in /var/www/data/e492c60b-7886-432e-b3e6-396e8db18795/images
[INFO] OpenDroneMap app finished - Thu Dec 07 01:07:15 2017
Postprocessing: /var/www/data/e492c60b-7886-432e-b3e6-396e8db18795
No orthophoto found at odm_orthophoto/odm_orthophoto.tif: will skip tiling
Potree point cloud will not be generated (no suitable input files found)
Postprocessing: done (•̀ᴗ•́)و!

Currently tiffs are not supported. See #451

Tiffs are not supported yet?

Correct. Tiffs are still not supported.