Error - Process exited with code 1

Hello everyone
First time trying to use WebODM
I’ve just installed it with an installer on cpu at the university.
It was kind of a hassle to be honest and I don’t know if it installed properly, but
VTX support is on.
Antivirus is disabled, but cannot disable firewall since it’s in the university,
I had a problem with docker saying that I was not a registered user, but it does not give me this error message anymore.

So, I’m able to go to the WebODM page with firefox, I’ve alocated more cpu ressources to docker, I uploaded 167 images and when I try to render them, everything stops after 1 to 10 sec and an “Process exited with code 1” error appear. I’ve tried it also with 46 images.

That’s pretty much where I’m stuck.
Please use terms and explanations a preschooler would understant.
Thanks

Images were taken with a MicaSense RedEdge-MX camera on a DJI Matrix 100 drone.
Link to the images: https://www.dropbox.com/sh/nviww2n3va55e76/AACF80W7daS7tyTID3EhPKsea?dl=0
This is the task output:
[INFO] Initializing OpenDroneMap app - Thu May 30 18:52:52 2019
[DEBUG] ==============
[DEBUG] build_overviews: False
[DEBUG] crop: 3
[DEBUG] dem_decimation: 1
[DEBUG] dem_euclidean_map: False
[DEBUG] dem_gapfill_steps: 3
[DEBUG] dem_resolution: 5
[DEBUG] depthmap_resolution: 640
[DEBUG] dsm: False
[DEBUG] dtm: False
[DEBUG] end_with: odm_orthophoto
[DEBUG] fast_orthophoto: True
[DEBUG] gcp: None
[DEBUG] ignore_gsd: False
[DEBUG] images: None
[DEBUG] matcher_distance: 0
[DEBUG] matcher_neighbors: 8
[DEBUG] max_concurrency: 6
[DEBUG] merge: all
[DEBUG] mesh_octree_depth: 9
[DEBUG] mesh_point_weight: 4
[DEBUG] mesh_samples: 1.0
[DEBUG] mesh_size: 100000
[DEBUG] min_num_features: 8000
[DEBUG] mve_confidence: 0.6
[DEBUG] name: 2d3f2281-ac0b-41ab-a89a-6c35433a4c4c
[DEBUG] opensfm_depthmap_method: PATCH_MATCH
[DEBUG] opensfm_depthmap_min_consistent_views: 3
[DEBUG] opensfm_depthmap_min_patch_sd: 1
[DEBUG] orthophoto_bigtiff: IF_SAFER
[DEBUG] orthophoto_compression: DEFLATE
[DEBUG] orthophoto_cutline: False
[DEBUG] orthophoto_no_tiled: False
[DEBUG] orthophoto_resolution: 5
[DEBUG] pc_classify: False
[DEBUG] pc_csv: False
[DEBUG] pc_filter: 2.5
[DEBUG] pc_las: False
[DEBUG] proj: None
[DEBUG] project_path: /var/www/data
[DEBUG] rerun: None
[DEBUG] rerun_all: False
[DEBUG] rerun_from: [‘dataset’, ‘split’, ‘merge’, ‘opensfm’, ‘mve’, ‘odm_filterpoints’, ‘odm_meshing’, ‘mvs_texturing’, ‘odm_georeferencing’, ‘odm_dem’, ‘odm_orthophoto’]
[DEBUG] resize_to: 2048
[DEBUG] skip_3dmodel: True
[DEBUG] slam_config: None
[DEBUG] sm_cluster: None
[DEBUG] smrf_scalar: 1.25
[DEBUG] smrf_slope: 0.15
[DEBUG] smrf_threshold: 0.5
[DEBUG] smrf_window: 18.0
[DEBUG] split: 999999
[DEBUG] split_overlap: 150
[DEBUG] texturing_data_term: gmi
[DEBUG] texturing_keep_unseen_faces: False
[DEBUG] texturing_nadir_weight: 16
[DEBUG] texturing_outlier_removal_type: gauss_clamping
[DEBUG] texturing_skip_global_seam_leveling: False
[DEBUG] texturing_skip_hole_filling: False
[DEBUG] texturing_skip_local_seam_leveling: False
[DEBUG] texturing_skip_visibility_test: False
[DEBUG] texturing_tone_mapping: none
[DEBUG] time: False
[DEBUG] use_3dmesh: False
[DEBUG] use_exif: False
[DEBUG] use_fixed_camera_params: False
[DEBUG] use_hybrid_bundle_adjustment: False
[DEBUG] use_opensfm_dense: False
[DEBUG] verbose: False
[DEBUG] video: None
[DEBUG] ==============
[INFO] Running dataset stage
[DEBUG] Loading dataset from: /var/www/data/2d3f2281-ac0b-41ab-a89a-6c35433a4c4c/images
[DEBUG] /var/www/data/2d3f2281-ac0b-41ab-a89a-6c35433a4c4c/images
[ERROR] Not enough supported images in /var/www/data/2d3f2281-ac0b-41ab-a89a-6c35433a4c4c/images

.tif files are not yet supported by ODM.

Convert them to .JPG then try again :+1:

1 Like

Or better yet, convert them to PNG so they aren’t lossy compressed! Although, that will lengthen the upload time.

1 Like

I have code 1 but seems a new problem. BTW I can get into Webodm from the Admin user account Win 10, but not my normal user account. Did all permutations of firewalls off on both accts.

app.log
“Booting WebODM 1.9.14 build 64…”
“Trying to connect to NodeODM localhost:29301…”
“nodeodm: info: Authentication using SimpleToken\r\n”
“nodeodm: info: Listening on 0.0.0.0:6367 UDP for progress updates\r\n”
“nodeodm: info: Initialized 0 tasks\r\n”
“nodeodm: info: Checking for orphaned directories to be removed…\r\n”
“nodeodm: info: Server has started on port 29301\r\n”
“Connected to NodeODM 2.2.0”
“redis-server: . \n .-__ ''-._ \n _.- . . ‘’-._ Redis 3.2.100 (00000000/0) 64 bit\n .- .-```. ```\\/ _.,_ ''-._ \n ( ' , .-` | `, ) Running in standalone mode\n |`-._`-...-` __...-.-.|’_.-'| Port: 29379\n | -. ._ / _.-' | PID: 11588\n -._ -._ -./ .-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | http://redis.io \n -._ -._-..-’.-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | \n -._ -._-..-’_.-’ _.-’ \n -._ -..-’ _.-’ \n -._ _.-' \n -..-’ \n\n[11588] 08 Nov 10:51:49.203 # Server started, Redis version 3.2.100\n”
“redis-server: [11588] 08 Nov 10:51:49.207 * DB loaded from disk: 0.004 seconds\n[11588] 08 Nov 10:51:49.207 * The server is now ready to accept connections on port 29379\n”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: waiting for server to shut down…”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: .”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: done\r\nserver stopped\r\n”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: exited with code 0”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: server starting\r\n”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 0”
“python: Traceback (most recent call last):\r\n File “C:\WebODM\resources\app\apps\WebODM\manage.py”, line 22, in \r\n”
“python: execute_from_command_line(sys.argv)\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\django\core\management\init.py”, line 381, in execute_from_command_line\r\n”
“python: utility.execute()\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\django\core\management\init.py”, line 357, in execute\r\n”
“python: django.setup()\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\django\init.py”, line 24, in setup\r\n”
“python: apps.populate(settings.INSTALLED_APPS)\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\django\apps\registry.py”, line 114, in populate\r\n”
“python: app_config.import_models()\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\django\apps\config.py”, line 211, in import_models\r\n”
“python: self.models_module = import_module(models_module_name)\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\importlib\init.py”, line 127, in import_module\r\n”
“python: return _bootstrap._gcd_import(name[level:], package, level)\r\n File “”, line 1030, in _gcd_import\r\n”
“python: File “”, line 1007, in _find_and_load\r\n”
“python: File “”, line 986, in _find_and_load_unlocked\r\n”
“python: File “”, line 680, in _load_unlocked\r\n”
“python: File “”, line 855, in exec_module\r\n”
“python: File “”, line 228, in _call_with_frames_removed\r\n”
“python: File “C:\WebODM\resources\app\apps\WebODM\app\models\init.py”, line 1, in \r\n”
“python: from .image_upload import ImageUpload, image_directory_path\r\n File “C:\WebODM\resources\app\apps\WebODM\app\models\image_upload.py”, line 1, in \r\n”
“python: from .task import Task, assets_directory_path\r\n File “C:\WebODM\resources\app\apps\WebODM\app\models\task.py”, line 34, in \r\n”
“python: from app.cogeo import assure_cogeo\r\n File “C:\WebODM\resources\app\apps\WebODM\app\cogeo.py”, line 9, in \r\n”
“python: from rio_cogeo.cogeo import cog_validate, cog_translate\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\rio_cogeo\init.py”, line 3, in \r\n”
“python: from rio_cogeo.cogeo import cog_info, cog_translate, cog_validate # noqa\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\rio_cogeo\cogeo.py”, line 13, in \r\n”
“python: import morecantile\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\morecantile\init.py”, line 14, in \r\n”
“python: from .defaults import tms # noqa\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\morecantile\defaults.py”, line 11, in \r\n”
“python: from .models import TileMatrixSet\r\n File “C:\WebODM\resources\app\apps\grass78\Python39\lib\site-packages\morecantile\models.py”, line 34, in \r\n”
“python: class CRSType(CRS, AnyHttpUrl):\r\nTypeError: multiple bases have instance lay-out conflict\r\n”
“python: exited with code 1”
{}

This AM’s section of pgsq.log
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started
LOG: received fast shutdown request
LOG: aborting any active transactions
LOG: autovacuum launcher shutting down
LOG: shutting down
LOG: database system is shut down
LOG: database system was shut down at 2022-11-07 12:33:00 EST
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started
LOG: database system was interrupted; last known up at 2022-11-07 12:33:01 EST
LOG: database system was not properly shut down; automatic recovery in progress
LOG: invalid record length at A/EDE385D0: wanted 24, got 0
LOG: redo is not required
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started
LOG: received fast shutdown request
LOG: aborting any active transactions
LOG: autovacuum launcher shutting down
FATAL: terminating connection due to administrator command
LOG: shutting down
LOG: database system is shut down
LOG: database system was shut down at 2022-11-07 12:56:19 EST
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started
LOG: received fast shutdown request
LOG: aborting any active transactions
LOG: autovacuum launcher shutting down
LOG: shutting down
LOG: database system is shut down
LOG: database system was shut down at 2022-11-08 10:51:49 EST
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started
LOG: received fast shutdown request
LOG: aborting any active transactions
LOG: autovacuum launcher shutting down
LOG: shutting down
LOG: database system is shut down
LOG: database system was shut down at 2022-11-08 10:59:28 EST
LOG: MultiXact member wraparound protections are now enabled
LOG: database system is ready to accept connections
LOG: autovacuum launcher started

Any ideas?